Updated to v. 2.7, now Scrivener won't start.

Hi guys,

I’m on OS X El Capitan (version 10.11.1) and was just prompted by Scrivener (I think I had version 2.6.50 before) to update to version 2.7. I’m using the “regular”/non-app-store version.

After allowing Scrivener to install the update, the following errors have appeared:

  1. The icons in the project template menu are gone
  2. Scrivener asks to update old documents when I try to open them - however, when I accept this suggestion the program freezes.
  3. When I try to create a new project from scratch, the file will appear in the designated folder, but once again when I try to open it Scrivener freezes up (sometimes locking all menu options so that they are faded out / I can’t select anything).
  4. I also can’t open the preference menu when I try to do it, but it will sometimes randomly appear without being called for.

I have tried the following solutions:
a) Restarting the entire system (twice)
b) Completely reinstalling Scrivener as suggested here: https://scrivener.tenderapp.com/help/kb/mac-os-x-troubleshooting/application-wont-restart-after-upgrade (I tried this step both before and after having deleted the previous version)
c) Launching Scrivener with the Shift key held down
d) Rebooting the entire computer with the Shift key held down after the startup chime

None of which have helped - the same issues arise. I have not tried to roll back the system using Time Machine backups, as I have not set that up yet. I have not installed any other new software lately.

What should I do now?

It looks like you’ve already gone through the most common suspects for a problem like this. The curious thing is that most of your description is precisely what we’d expect to see from a damaged automatic software update, fixed by doing what you already did: installing from a fresh download. The lack of icons and inability to properly create basic windows like projects and even the template chooser are all common to this kind of issue.

There is one bug in OS X 10.11 that can cause Scrivener to crash on start-up (which doesn’t precisely match what you’re describing, but it is worth a try), described in the knowledge base article, Scrivener crashes after upgrading to El Capitan (OS X 10.11).

If that fix didn’t work, what would help is to send in any crash reports or console messages you’ve been getting. From my first guess, it sounds like your system is having difficulties loading graphics for some reason.

Thank you for your reply, Amber!

I tried the method described in the link you provided, but the simple way of doing it didn’t work ( it couldn’t find the .GlobalPreferences table ). Instead I created another admin account and opted for resetting the preference that way. This didn’t work either.

However, when using my second admin account, I noticed there were two different Scrivener installations in my Applications folder (one dated August 26th 2015 and one dated in 1984). On my ordinary admin account I could for some reason only see one of these. I decided to delete them both and went back to download Scrivener 2.6 (i.e. the last version I knew to work on my system) again.

The old version (2.6) preliminarily appears to be working, although it installed itself on my iCloud drive instead of in the applications folder, which at first led to some initial confusion on my part (the desktop shortcut wasn’t working, and Scrivener wasn’t listed in the applications folder - in retrospect for an obvious reason, given that it wasn’t actually there). I will continue to use version 2.6 with some caution for a while (hello, extra backups), but hopefully it should work as it did previously.

That said, I’m still interested in finding out why version 2.7 didn’t work.

I have saved the log file from one of the “crashes” of version 2.7 - would you advise me to post it here or to submit it via e-mail?

I’ve seen a couple of similar situations, with people reporting the same symptoms you have and multiple versions of Scrivener in the Applications folder.

What has worked for them is to remove all copies of Scrivener, and then reinstall version 2.7 from a fresh download. Version 2.6 does have some known issues with El Capitan, so you’ll probably want to upgrade at some point if possible.

Katherine