Updating project to new version kills the project -- help

I’m currently using Scrivener version 1.055b. I tried upgrading to version 1.03 (the current version on the website). When I open my existing project, which is about 39mb, I get the following message:

Welcome to Scrivener

The project you are trying to load users an older format and cannot be opened. Would you like to update it? A copy of the old project will be saved in the same directory.

When I select the option to update the project, a new copy is created, but there are not files in the project, just the trash. The backup copy is similarly hosed. If I examine the contents of the .scrv package of either copy, it appears as though there are some files left in there, but the project is completely unusable in Scrivener.

Luckily I have nightly backups of my project and my old copy of Scrivener, so I was able to revert to the old project and v1.055b.

Obviously, I would like to upgrade to the new version, but is there any way I can do this without hosing my work?

Given that you are using a beta version, you need to check the Beta Testing forum. You upgraded from a newer version (1.055b) to an older version (1.03). There was a bug in older versions of Scrivener whereby older versions mistook newer projects for older projects, tried to open them, and irreversibly corrupted them. Don’t worry, though, a backup has been created in the same folder. Update to the latest beta (1.095b) and open the backup in it (which will have had “Old_backup” appended to it).