updating to Catalina 10.15.2 Scrivener hangs

I have been getting a recurring problem with Scrivener. It starts when I open another project, after having worked on others. I get the beachball for ever. I kill Scrivener… and thereafter it won’t reopen. Sometimes it appears open in the Dock… sometimes not. If I hit option-command-escape I am told that “Scrivener is not responding”. I have discovered that the only way to get Scrivener working again is to restart my computer.

this was not happening before I upgraded to Catalina MacOS 10.15.2

What version of Scrivener?

Does it matter what the second project is? That is, does the same project always hang?

You can start Scrivener without any projects by holding the Shift key when the program starts. Does that work, or do you still have to restart the computer?

Katherine

3.1.4

it’s not project specific… but seems to depend on how long the computer has been running since a Restart. When I’ve been forced to Restart before, I’ve managed to open project fine. But then, at some point, when I open a new project, the app hangs with a beachball turning for ever.

the experience I have just had is that I have had the computer running for many hours post a Restart. I’ve not been using Scrivener (our Xmas partying!). I just tried to restart it. I opened a project… I didn’t get the usual dialogue window compiling the ‘search index’ (whatever it is). I checked and it says that Scrivener is “not responding”. I killed the process and tried again. This time the app merely bounces for ever in the dock.

thanks

have you any idea what the problem may be…? this is making it impossible for me to use Scrivener… and is affecting my work negatively…

Since it only happens when you’ve been away from Scrivener for a while, you might see if the autoclose option helps. Scrivener -> Preferences ->General ->Automatic Quit.

To get more information about what might be going on, open the Activity Monitor application (in your Applications/Utilities folder), locate Scrivener in the list of processes, and use the View -> Sample Process command to see what it’s doing. Send the result to our support address, with a note that it relates to this forum thread.
literatureandlatte.com/contact-us

Katherine