Upgrade not working

I currently have the 1.9 version of Scrivener, and tried to upgrade to the new version 3. I followed the steps for the free upgrade, but I keep getting an error message. I uploaded the screenshot of the error. Any idea on how to fix this? I already check for upgrades on my current version and it says it’s up to date.