Upgrade to 3.2.2 from 3.2.1

I don’t know if this info is of any use to you.

MacAir 11", early 2015;Mac OS Catalina (10.15.7); Express VPN activated
I twice tried to make this upgrade, and both times the update failed, and the message said to try again.

MacBook Pro (mid 2015) Same OS. ExpressVPN not installed yet. The upgrade worked fine.

Shutdown the Air and re-started it. Without ExpressVPN running. Upgrade worked fine.


I have a MacBook Air 11 and I’m on 10.15.7 as well. I had no problems upgrading, but then I use the Tunnelbear VPN. – Just another data point.

I use ExpressVPN (EU servers) as well, and I had no problems upgrading. I would suspect some other factor is involved, as the transaction itself is fairly straightforward, and conducted over standard HTTPS port 443 for both the version check and download, that latter of which will come over the Amazon S3 network.

Do you use Little Snitch on the this machine or any other firewall/port blocker? That would certainly be something to double-check, if so.

Well, worst case just download the DMG and replace the current copy with that.