Upgrade Went Badly Wrong


I tried to upgrade to 2.0 today, but now nothing works. Here’s what I did.

I cashed out from the Scrivener site and clicked the link, downloaded 2.0 and dragged it into my applications folder. It asked me if I wanted to replace the existing “Scrivener” and I said I did.

Then, I asked me to authenticate the change. I typed in my password, but then it said that I did not have the authority to change the applications folder.

Now not only does my upgrade not work, neither does my original copy. I can’t open the program at all.


Have you tried deleting any existing Scrivener app from the Applications folder? That usually does the trick for me when this or the other typical error happens (this being “so and so is in use” so I can’t overwrite). No existing app = no complications when replacing apps which might still have components in use by the system.

Alternative: Change permissions on your Applications folder to no longer require admin access.

Actually you may want to run the “fix permissions” from disk utility. Go to Applications -> Utilities -> Disk Utility. Select your boot volume in the left hand pane then click the fix permission button. Let that run then try again.

If that doesn’t get it let us know.

I would not suggest manually changing the permission unless you are very comfortable with it.

I also had the same problem in upgrading. I tried repairing the disk permissions but it didn’t help. My 1.54 version is now broken as well. Help!

Are these the steps you followed:

  1. Download scrivener.dmg
  2. open dmg file.
  3. Accept the terms
  4. In the window drag the scrivener icon to the application folder
  5. enter the admin password if asked.

I just deleted the old Scrivener 1.54 using AppCleaner and then dragged Scrivener 2.0 into the Apps folder. It installed fine. Problem solved for me.