Urgent: Reward for help with the non-saving bug

Verita, had meant to answer you – that is very useful to know what solved your case, and I’ve noted it in another thread. Thanks for posting it.

ayeka, great to see Revo has removed the 30-day limit for their trial, and made a free version available that ought to be able to help anyone with multiple Scriven installs showing.


Thanks Randy, I appreciate all the feedback. The points you make above are all worthy of implementing in the installer and the update installer code.

Moving ASpell out of the main Scrivener directory into C:\Users{username}\AppData\Local directory to allow the complete deletion of the Scrivener directory on uninstall is a good idea period.

Scrivener HQ has been changed in all instances to Scrivener. This change went in in 023 and will remain - all references to Scrivener HQ can be deleted.


I’m very glad to see Scrivener will start performing fully clean uninstalls. Left behind files is always a recipe for future trouble, which is one of the reasons I also always use Revo Uninstaller, which was mentioned by someone else on this board. I’m glad to see the problem seems to have been found, and we can hopefully start moving forward again.

Keep up the great work!

Sadly, I’m here to confirm that a complete uninstall does not fix the non-saving problem. I did a complete uninstall prior to installing .23 and just lost text. Significantly, to me, it is in the same document that it was in when I lost text in .22. In other words, it’s dropped the same scene twice. (I didn’t lose the work, because I’m compiling at the end of sessions.)

I’ll send you the file, but here’s what I did.

Opened Chapter 18 and wrote.
Moved to Chapter 20 and wrote.
Went back to Chapter 18.
Saved the document and closed it.

When I reopened it, I was in Chapter 18 but the new text was missing.

I tried again, and got the same results.

I tried again, this time NOT going to chapter 20 and the text in Chapter 18 had been saved.

Now, however, repeating the above steps is not resulting in a failure to save. Sorry that this isn’t more helpful.

1.) Windows Vista
2.) Admin account.
3.) IC:\Documents and Settings[username]\My Documents\Dropbox\Dust

Sorry to hear that the issue has persisted for you. When you did the complete uninstall, did you happen to delete the leftover Scrivener folder in Program Files before reinstalling Scrivener and then do a reboot? Not sure it would make a difference, but there has been some discussion about left over files even after doing an uninstall.

Also, are you saving to a directory that is being used by Dropbox? If so, I’d be curious to see if changing to a non-syncing folder makes a difference.

This is happening intermittently for me, so I don’t think I will win the $200, but maybe this will help.

It’s thus important that you state:
1.) What is your operating system? Windows 7
2.) Is your account admin? Yes
3.) Where are you saving your scrivener project file? In a Dropbox backed-up folder
4.) What format is the drive you’re saving the project to? NTFS
5.) What is your ‘Save after period of inactivity’ set to in Options>General? 2 seconds
6.) and as much relevant information as you can so that Lee can reproduce the same situation as closely as possible
A. This has usually happened when I put my computer to sleep with the program still open, then open it again. I think it happens only for files that I edit both before and after the computer sleeps.
B. It appears to be auto-saving. The asterisk disappears.
C. In a session, some files may save while others will not. Again, I think that the files that don’t save are the files I was working on while it slept.
D. I have Scrivener running on two computers that access this folder, but this has happened when I have not accessed it from a second computer.
E. I have not had an earlier version of Scrivener running on either of these computers before.

I’ve deleted the leftover files and done a reboot. So far, save is working.

Had to take an article out here, as realized the beginning had to be altered by the conclusions.

It’s going to be about DropBox and Scrivener, when it returns.

Regards to anyone who started reading it, and please wait for the final version.


Glad to see things are working for you–at least so far. Is there anyone still experiencing the save issue who has not uninstalled, deleted the leftover Scrivener folder, and reinstalled 023? I’m sure hoping this resolves the issue for good!

Only the 023 version is installed on my Windows 7 machine. I am not having this problem, BUT:

If opening a project is related to saving a project, I note that my Mac-created file had a “conflicted copy” set of files in the main folder when viewing it in Windows (I keep my project files in Dropbox). I had never been able to open that one file, but I could other Mac-created files. So I deleted anythong that had “conflicted” in the file name (they were weeks old).

Voila. The file opens now, and saves changes as I go between machines. Perhaps others are having odd things happen due to extraneous files sneaking into the project folder.

Apologies if this is a diversion,


Ed, it’s not a diversion.

People using DropBox directly on active Scrivener projects are going to have real problems due to DropBox’s design, even if they haven’t seen them yet; and I think those problems are showing in the remaining few who have saving reliability issues, according to bug reports.

I’m back on doing a write-up of this – wanted to verify a few issues and give solid workaround. I also had to break for something else for a day.

I think this will be the last item to save Lee from his moment of hair-tearing, and bring back all confidence that besides Scrivener being the best writing tool since sliced bread, it is entirely reliable.



All true, but many of the largest problems inherent in placing a large set of integrated files together on an automated network-based relay can be avoided with a few simple steps. We have a forum post here. Also, much of this information is also in the user manual in the Cloud Integration and Sharing chapter (pg. 67 in the preview PDF).

If you don’t follow these guidelines though, you are correct. Failure to keep in mind the network latency factor when shutting down and starting up can cause all kinds of issues. That all said, unless you’ve got problems with uploading and downloading, using Dropbox shouldn’t cause data loss. It’s primary malfunction is the proliferation of safety data in those conflict files—so the opposite problem really.

So consult these two articles when you write your piece on it. It is possible, you just have to be more cautious about things than you can be on a local drive.

Ioa/AmberV, great. I’m glad I checked back while I am writing my piece.

Scanning through that posting,

  • it’s on the Mac forum, so not likely anyone here has yet seen it
  • it covers how to often have Dropbox work if you are only using it yourself, to transport files across two or more of your own machines.
  • however, it is tricky, and prone to failing even then. As the article acknowledges, if you do fail, the results can be corruption of a project, lost text even if apparently not corrupted, and so forth.
  • if you actually collaborate with someone else over Dropbox, then all bets are off, and you are indeed quite likely to see any of the corruption, lost saves, lost prior text, etc. happen.

This is all down to how Dropbox does and practically, must work; and the system that is otherwise completely advantageous about how Scrivener does.

What I am going to do is suggest another way to use Dropbox, which I believe will be successful and easy to adopt. Let me do that, and then you all can criticize however may seem appropriate.

In a short while, and I’ll put the posting in the main list of postings, so it can get discussed there, on its merits. Hopefully without too much input from me.


Duly noted. Perhaps one of the general Usage boards would be a better place—with some cross-reference posts in both Windows and Mac tech support forums. That should catch most entry points.

That’s a good point. It’s quite possible to collaborate (we have one or two .scriv files amongst the team that we do this with), but good communication is essential, and under no circumstances should more than one party be in the same project at once. That’s just true of anything, not just Dropbox, but given the temptations, it wouldn’t be a bad idea to reiterate that up front.

Yup. Both systems are using the best technological solution to their particular goal, and these solutions do clash. For Scrivener to remain a robust system capable of managing massive quantities of research data in a transparent fail-safe way, it must use a file and folder storage system. Dropbox is all about files and folders, but is optimised for single-file data that is always visible. It’s one thing to get a conflict file on your Word document, and quite another to get a conflict in some obscure sub-sub-sub-folder on a file named “21.links” or what have you. Not only is it hard to find or be aware of its existence, but unless you understand a few XML principles, or how a text file is really just a very long number with links described as byte offsets against that number—well good luck merging that one properly.

Anyway, anxious to see your results. We better let this thread go back on topic now.

All agreed, I think, Ioa…and the article is up in the main thread.


I am so glad I have seen this thread as my save sometimes works, sometimes doesn’t. I have not un-intalled any of the scrivener programmes - been too scared as I have had problem with back up from the start. I now back up to pen drive as well, but now my programme is crashing - so having read this I will uninstall - pray that the usb will keep everything and then re-install and see if that solves the problem.

I am not computer literate at all, and had hoped that each ‘new’ version would work off the old one - the way most programmes do - will be the be the case when the programme is finished?
I love scrivener, but am getting too scared with it not saving or backing up.

katielara, I hope and expect that the steps of uninstalling, then removing C:\Program Files\Scrivener, then reinstalling with the recent 023 installer, worked well for you.

It could be C:\Programme\Scrivener, depending on where you live, as Windows install is sometimes a bit different this way.

As far as Scrivener backing up, it’s only backing up to a zip file that is presently broken, and I expect that to be fixed with an update that will come out shortly. Meanwhile, you can still back up to a folder, and those folders are automatically named with time and date, so it is just as easy.

I am very sure that Scrivener will be entirely reliable in all ways at the time it’s released. This is why we have Betas in the world, to notice and root out what’s unexpected.

Wishing you a nice week-end,

Ok, this is the first time the non-saving has totally messed me up - a whole scene gone. The thing is, the other editing I did last night is still there, just one scene is gone. So I thought if I posted this, it might help someone to recreate the problem.

So here’s what I did:

Last night I edited several text parts of the manuscipt including the text and the synopsis and the notes of several different documents. All of this saved successfully as far as I can tell.

Then, immediately after this, I added text to an existing document that was previously blank. I added lots of text, bringing my total page count from 91 to 94. I remember this because just before exiting I checked this.

Before and during typing this text I added a number of photos to the research folders and also rearranged the folders. This all saved successfully.

Finally, I finished typing the text - which I’m freaking a little about losing, since it was a hard part to write (ok, end of the why-me part), and then I watched tv for several hours. I returned to my computer and decided to exit out, at which point I noticed that I had not assigned the label or the status for the scene I had just typed, so I did that. I don’t remember manually saving, but I definitely do remember checking to see if the little asterix was gone, since it had popped up for a second when I changed the status. It was gone.

I had two program files open, so I exited out of first the file I had been editing, and then the other file.

Next day - I open the program, (the 2nd file comes up first, and then I file/open the file I worked on) and the whole scene is gone from the manuscript - except - and here’s the kicker - the label and status are still set. What? The other editing seems fine - I had a serious past-tense problem that I edited last night before writing the scene. That’s all still fine. The research is still all there. For some reason, it just decided to delete all the text in the last page I was in.

What the %*@?

I can’t recreate the problem. I’ve tried like 30 times. No-go. Maybe this info can help someone else figure out how to recreate it.

What I think is really weird is that the status I altered at the very last saved just fine, but the text that I spent hours writing before I altered that status was gone the next time I opened the program.

Is there seriously no way to find this? Maybe it isn’t really a saving problem - maybe it’s an opening problem. Is it possible that it saved just fine, but that something in the program glitched and deleted text when I opened it the next day?

Has anyone else had anything other than manuscript/draft text not save properly?


I had saving issues with beta 022, like other people, but nothing bad has happened to me with beta 023 so far. I hope they find this remora saving issue soon, because such a fantastic software like Scrivener doesn’t deserve this uncertainty (even it is very unlikely to happen with 023).

Here are my observations, if it helps:

I just started having this bug a few days ago, right after I began to sync up my files to Dropbox (it had never happened before). At first I thought that it was Dropbox causing it, so I have since disabled syncing to it.

I have lost the entire contents of documents, and sometimes just the newest text added to the end of a document. I also (just this morning) saw where some changes I had made to an index card were not retained. It seems that only the most recently added text is affected; if it makes it through one save, then it sticks around.

I’m using Windows 7, on an account that I have administator rights on.

Now, I just checked my version of Scrivener, and it seems I have the 0.22 version. When I get home from work tonight, I’ll try an uninstall and install of 0.23 and let you know how it goes.