URL blocked because of cookies consent

When I add a URL directly from Safari to the binder, it is blocked with a cookie consent banner. It is impossible to click on “Accept”, and I can’t have any access to the page in Scrivener.

In Europe, because of UE regulations, most websites have these kind of banner.

It’s a pity how poorly designed some of these cookie “requests” are. There isn’t much we can do about it though as the viewer in Scrivener is just an extension of how the Mac displays web pages. You can try saving the page from Safari as a .webarchive file after clicking through. In Finder, press the Spacebar to view it in Quick Look. If it looks fine there, then it should also be fine dropping the saved file into the binder.

And if you don’t really need the web page and just want the text, try changing the setting to Convert imported WebArchives and web pages to text, in the Sharing: Import preferences tab. 99 times out of a 100 I don’t need the website design, and never navigation and ads anyway, and certainly not their cookies and trackers running in the background, I just want the text.