Using Project Targets in a Single Folder within Manuscript

Greetings, I am using a single Scrivener file to compose and organize a number of books in a series, as well as short stories set within the same fictional world. I’m interested in using Project Targets, but can’t seem to find a way to limit the total word count to a single folder (with multiple sub-folders and text documents) within the main Manuscript folder.

The options in the Project Targets window seem to indicate that I can limit the “focus” to a single compile group. I tried setting up a custom compile group for a short story and saving the settings. Had a bit of difficulty there, as it seems I had to actually run the compile in order for the settings to “stick,” clicking “Update” didn’t do the trick.

In either case, this action had no effect on the Project Targets, no matter what I do it seems intent on adding up all the words it can find in the Manuscript folder. I know I’m probably missing something obvious. Could someone nudge me in the right direction?

Edit: Oops, my user platform indicates Windows but it is now Mac. Thanks!

This is what I do when I want Project Targets to only reflect one book/story in a series, though I seems you’ve done all this…

  1. Create a folder for each book/short story, and move all files & folders from the top level of my Manuscript folder to those folders.
  2. Go to File->Compile, Expand to “All Options”
  3. In the Contents pane, choose the book/story folder I’m working on from within the Manuscript folder. There’s a drop-down list above the table of your compile group’s contents (the table being the one with the columns: Include/Title/Pg Break Before/As-Is).
  4. Hold down OPT and click Save
  5. Click the “Options” button in the Project->Targets window, and choose “Target applies to current compile group only”.

That works for me. Every time I change the appropriate folder under Manuscript, the progress number changes to reflect the number of words in that part of my project. Is there a step you’re doing differently from above?

That’s resolved it, thank you robertdguthrie!

The only step in your list that I’d missed was the OPT-Save, which I didn’t know about. I was using the “Update” button under “Manage Compile Format Presets…”, and apparently that was the issue.

Thanks again,
CJ