Using sequential numbers as section titles in a short story (two questions)

Hi all,

Two problems, one of which looks like a bug.

1 ­– I’m using <$n> at the start of each section (“Scene”) in a short story. I marked each such paragraph “Keep with next” and verified the flag is on with each paragraph so flagged.

And yet, I have a persistent scene header (“3”) hanging out on the bottom of one of the PDF pages.

  • Is there a fix for this, or is it a known bug?
  • Is there some underlying code I can inspect and tweak to fix this?

2 – As I said, I’m using <$n> for section (“scene”) headings. And I’m doing it by placing the placeholder/counter in the text.

Is there a better way to do this? Like at compile time?

Thanks!

Thomas

Bumping this. The bug is serious. As it stands I can get no distributable PDF for the story.

I fiddled a lot with Compile settings last night to use the compiler to insert the section numbers (there seem to be two ways to do this) and I could not find a setting that didn’t strand a section number (“title”) at the bottom of one of the pages.

I’m using the compiler PDF preset settings as a base. I think there’s a bug in this one. “Keep with Next” should be automatic for titles, right? Seems not to be.

I can provide examples, but this should be easy to test.

Thanks,

Thomas

These forums are primarily for user-to-user assistance. To ensure a timely response from L&L staff, please open a support ticket, here:

I’d advise doing so in this case, as it will probably be faster for us to just look at the project directly.

Yes, the “Scrivener-like” way to auto-number sections is via the Compile command.

“Keep with Next” is not automatic for titles, which often reside on their own page.

Thank you. I’m mainly used to the beta 3 forum which did serve as a bug repository, so point taken.

About this:

Yes, the “Scrivener-like” way to auto-number sections is via the Compile command.

“Keep with Next” is not automatic for titles, which often reside on their own page.

What’s the Scrivener-like solution? I can format the paragraph containing the title in the Compiler formatting tab, but “Keep with Next” is not one of the options I can apply.

What do others do in cases like this?

(I think the tricky part of this case is that it’s a short story, so “titles” are really just Scene numberings, and are meant to be consecutive, not on new pages like chapter titles. On the other hand, not all numbered headings / section titles are the tops of pages…)

Thanks again,

Thomas

Hi Thomas,

It seems to me that the tab Separators in the Compile Format Editor escaped your necessary attention.
Double-click your Compile Format and find the Separators tab on the left-hand side of the screen, beneath Section Layout.
Setting the separators for the Headed Sections Section Layout to Single Return or Empty Line will Compile all scenes after each other, without any Page Break between them.

HTH

Thanks, AntoniDol. I did try lots of those combination, but I’ll try again.

The problem I’m trying to solve is that I get page break splits just after the scene “titles” — actually just numbers. I have enough scenes that there’s no combination that keeps one of them from ending up at the bottom of the page. I’m dying for a “keep with next” control I can apply to the title paragraph in my Scene format.

I’ll test out your suggestions. Thanks for the thought.

Thomas

Maybe it’s an idea to compile to Word, repair the Scene numbers that end up at the bottom of the page and generate the PDF from Word?

1 Like

Have you enabled widow/orphan control?

Where is that? I’ve searched the manual for "widow’ and found nothing. Same with searching Help (Shift-F1).

Thanks,

Thomas

My mistake. That feature hasn’t come to the Windows version yet. I’m sorry for the confusion.

It sounds like the fundamental issue is that the title + text simply won’t fit in the available space, so you need to force a page break before the title. Absent widow/orphan control, the best solution is going to be to review the output document in your preferred editor and generate a PDF from there.

1 Like

How about if L&L added “Keep with Next” as a paragraph formatting option in the Compiler? Today, titles can be formatted differently in the Compiler than regular body text. Just add one more control to the formatting bar. A thought…

I’m avoiding going to a separate program for PDF generation, since that basically obviates the point of using Scrivener for text creation.

Thanks,

Thomas

Scrivener has never claimed to be the only application you need to produce publication-ready PDF files. If you think using a separate program for PDF generation makes Scrivener pointless, you are probably not taking full advantage of Scrivener’s text creation capabilities.

Thanks. This isn’t about thinking it’s pointless. I won’t move away and I love it’s other features.

But this problem seems a small oversight and easy to fix. I hate workflows that use multiple programs for post-processing because the original post-processing program doesn’t have a feature that another one does.

After all, is it reasonable for an authoring tool to assume that every section title of every manuscript type falls on a new page? Shouldn’t Keep With Next for titles already be an option?

Sorry — frustrated. I’ve put too hours into solving a simple formatting problem on a story that’s ready to send out, only to find out it’s unsolvable in Scrivener. The idea of going to Word (ugh!) or a workalike, which could be another timesink, is depressing.

Thanks for all the advice.

Thomas