Using the Compiler

Oh good, I’m glad the Print Preview is working now. Running that forces Word to figure out the layout for printing, which means updating all the internal references for page numbers, etc. so it’s kind of “seeing” for the first time where the linked RTF bookmarks are falling in the layout.

I have nothing against Word XP. I rejoice that it does not have The Ribbon and would not try to dissuade you from using it. I rarely use Word at all these days outside of testing, but I have the newer versions installed on the Windows 7 machines I use more frequently for that, since they’re more common.

In the Separators tab of compile, choose “Custom” as the separator between whatever file types you have for your character sheets (if they’re all text files, you want the text/text separator; if some of them are folders, you’ll need to set others–you could just set the same custom separator for everything and it should be fine) and then enter the character there.

You might want to make other changes and save it as another preset–for instance if you have a header and footer normally, you might not want that here, or you might want a different one that just indicates the title of the project the character sheets are for, etc. Once you have it set as you like, just choose “Save Preset” and give it a new name.

Yes, the Ribbon is one of the reasons I am resisting going to later editions of Word. I dislike it immensely.

I suppose the Print Preview thing makes a certain amount of sense, but it certainly was confusing. Now that I know what the situation is, it’s worthwhile.

Found it. I’m experimenting back and forth to be sure what I’m doing actually works before sending it to my co-author. She’s even newer to Scrivener than I am, and gets frustrated very easily if something doesn’t work instantly.

I exported the Character folder, using # as separator for everything, as a .doc file. When I attempted to re-import the file Scrivener had just created, I got a converter error. Scrivener said the .doc file it had just made wasn’t a .doc file. So I re-exported it as an RTF file, and that imported okay, except…

(You knew it was coming, didn’t you?)

The structure of what I compiled was

Character Folder
Character Type 1 Folder
Character Name Text
Character Name Text
Character Name Text
Character Type 2 Folder
Character Name Text
Character Name Text
Character Name Text
Character Type 3 Folder
Character Name Text
Character Name Text
Character Name Text

What I got back, on reimportation, was a single folder claiming to have all the items in it. When I clicked on the folder, it displayed, scrivenings style, all of the documents I had imported. It says it has X files in it… but I can’t open the folder to access them.

I deleted the folder, and tried importing it straight. This time, I got a text document which SAYS it has all the documents in it, and again, I can see them as one long scroll, but cannot access the separate documents.

FYI, Character Folder is flush against the left margin of this message, Character Type Folders should be indented one level, and each of the Character Documents should be indented under the Character Type Folders. It shows that way in the edit panel, but everything is flush left in Preview.

Right. Once I figure out how to get this to work!

Sorry, this is a problem with the importer when working with a compiled .doc file using the “RTF-Based” converter. Compiling straight to RTF will be best for this, since you’re just passing it off to your collaborator for re-import.

This I think is a bug we’re in the process of fixing for the next relesae. If you select the folder into which you’ve imported the documents and use the RightArrow key to expand the folder, does that work? There’s a bug right now where the disclosure arrow in the binder isn’t appearing on the Import & Split until triggered by some change to the folder like dragging and dropping the subitems. For instance if you select the folder and load it in corkboard or outliner mode (select the view mode from the View menu or using the icon buttons in the main toolbar), you can move one of the documents in the editor and it will display the disclosure triangle in the binder. Then just move the doc back to its proper place.

Check, no problem with doing that. I was just automatically going for the Word doc, since she’s more likely to look for one of those, but I’ll explain.

Why does it figure I’d find I not-yet-fixed bug? Well, you’re aware of it, and it’s being worked on, so I will just have to be patient on it.

RightArrow didn’t expand it. Shift+RightArrow, however, did.

The expansion is all files, with no folders.

People Category 1 is now a document with only that in it. Ditto Categories 2-whatever.

All the character sheets have been renamed to the first line of the actual text, where before, they had the names I had given them.

If desired, I can send you a screen shot of what the output folder looks like, and what it looks like when re-imported.

(Argh… my head hurts. Not only this, but I got my husband a new smart TV and blue ray player for Christmas, to replace a 19" CRT that is around 20 years old. The Smart TV is making both of us feel very dumb! Hope you have a Happy Holiday!)

Import and Split divides the document at the custom separator and uses the initial text of each document as the title. If you want to make sure the documents when imported use the same title as in your project, compile with the “Title” checkbox ticked for both folders and documents. That will mean the title is also added to the document when imported, but it may be a nicer solution for you than having the other text as the title. Worth experimenting at any rate.

Import and Split won’t preserve any kind of hierarchy or a folder vs. file distinction; once you compile, remember, it’s just a flat text document, and on import it’s just chunking that document into multiple. But if you’ve got everything titled the way you want it, it shouldn’t be difficult for your collaborator to select all the “Type” documents and then right-click and choose “Convert to Folder”. Then she can select the documents between each set of folders and use the Ctrl+RightArrow shortcut to move them inside the folder as subdocuments.

I’ve attached a basic compile preset you can try, if you want to give it a look. Just download the zipped file, then double-click to open it and drag the “DocsToSplit” file to your Desktop. In Scrivener’s compile settings, choose “Load Preset” and “Import” and browse to that file and choose “Open”. Select the newly imported preset in the list and click OK to set it as the current preset (and also make it available in other projects). It leaves your editor formatting, but you may want to adjust the formatting for the titles to match whatever font you use; it’s just Courier New at the moment.
DocsToSplit.zip (1.56 KB)

Ah, okay. Adding the title to the document isn’t a problem. In fact, I was thinking of doing that anyway, in order to have the title show up in the first line.

Ah. That makes sense. I thought that by putting the correct separators in, it would automagickally recreate the hierarchy’s structure when importing and splitting. No big deal to do as you suggest. And as long as I write out step-by-step directions for my collaborator, it will be fine.

The problem was my not understanding clearly what Scrivener was doing when. Ya can’t explain it to someone else if you don’t understand it yourself.

Thank you very much! Yes, I’ll want to switch Courier New to good old Times Roman 12. I’ll test this out after I get the cheesecake in the refrigerator.

OK… on to the next Compiler question.

I need the chapters to come out looking like the following clip:

ScrivenerChapterLayout_2014-12-26A.JPG

Scrivener will take care of adding “Chapter” and the Chapter Number after it in the compile.

I know that Scrivener will take care of formatting the actual text, starting in this case with “As much as Quentin MacCullough.”

It’s the part in between that I am not sure about.

Since it’s pretty highly formatted, and will change from Chapter to Chapter, I’m guessing that the best way to set this up in Scrivener is to have a document with something to tell me what it is – in this case, Quentin’s Arrival, and then have two sub documents under it, one with the Chapter Header, and the other with the Chapter Text.

Hmm, I have some more clips, but the software says, “Not so many in one message!”

ScrivenerChapterLayout_2014-12-24B.JPG

I know I’m going to want to do this as a Preset once it’s tweaked into place.

So then when I go to Compile the whole thing, I need to begin by setting it up thus:

And then I proceed through the selections, I think, thus:

(to be continued… too many clips…)

Continued from previous message. Trying to show what I have so far, and the fact that I cannot figgure out how to set these up to achieve the layout in the replaced example. (Note, “99-2A” is not a useable Chapter number. It’s just one I used in Word to denote a piece I’ve written, but which does not yet fit into the story line. One reason for diving headfirst into Scrivener because of the ease of reorganizing sequences. I’m a chunk writer, rather than a linear one.)

Still tinkering… hopefull picking up where we left off before the holidays!

Yep, thanks for your patience! I hope you and your cheesecake spent a pleasant holiday. :slight_smile:

I think you’re spot-on with your binder structure. There are a few ways to achieve the formatting you’re after, but what you’ve got I think is the most straightforward. The only alteration I’d make there is to change the chapter container (called “Quentin’s Arrival” in your screenshot) to a folder, and that only because it will give you a little more freedom with the separators and titles. You may not need that in your project, though, so I’ll just explain my thoughts as I go through and you can see what suits you best.

So you’ve got a setup like this:

Chapter container - compiles the prefix only, e.g. “Chapter 1”, formatted in the compiler
– Chapter Header - compiles text only, formatted exactly in the editor and marked “as-is”
– Chapter Text - compiles text and possibly title (in your example, you could make “Canada: Spring, 2152” the title), formatted in the compiler. If you compile only the text, the “Canada…” line will need to be formatted exactly in the editor and marked with “Preserve Formatting” so that you can maintain its unique indentation and spacing.

Using the title for the “Chapter text” document makes the most sense if all your chapters have a section title like this, since you’ll be able to adjust the formatting easily in one place. If that alters per chapter, where some have it and some don’t, you’ll need to just include it in the document text and apply Preserve Formatting. If you change the formatting you’ll have to adjust it on all the documents with this, but it will let you then have some chapter documents compile without a title.

If you do have a section title like “Canada…” for every chapter but have multiple “Text” documents per container and there should only be the one title, i.e. you’ve got

Chapter
– Chapter Header
– Chapter Text scene 1
– Chapter Text scene 2

and so on, you can still compile the title easily by changing the structure so that the first chapter text document is a document group, with the remaining text documents as its children:

Chapter
– Chapter Header
– Chapter Text scene 1
---- Chapter Text scene 2

In compile formatting, you can then use the same formatting for both the document groups and the single documents, but you can include the title for only the document groups. In this case, you’ll see it may be easier to have the “Chapter” container be a folder instead of a document group, although it will work either way as far as titles; if both are document groups, you’ll need to just select the document group row in the compile formatting and click the “+” button to create a new level. Then you can set it up so that the Level 1 document group row has just the prefix, formatted however you want it, and your Level 2+ row has no prefix but the title and text included, formatted as you want.

Spacing is the other factor in this. For the “Chapter Header” documents, you’ll just format that exactly in the editor, so you can apply the proper after-paragraph spacing for the first and last lines as well as the specific indentation and character formatting needed. For the “Canada…” type titles, either you will format that in compile by selecting the “Title” sample text and applying the needed after-paragraph spacing (choose “More…” from the bottom of the line spacing menu) or you’ll format it exactly in the editor and use Preserve Formatting. You should use the “Single Return” separator between text documents in compile so that no extra spacing is added between your “Chapter Header” documents and the following text.

For the spacing between the “Chapter 1” title and the following chapter header text, you have two options. If you use a folder for the chapter container, you can set the Folder/Text separator to “Empty Line”. This will use the point size of the “Chapter” prefix, so if that seems too large for you, you can instead use the “Single Return” separator and then apply the exact amount of after-paragraph spacing you want to the prefix in compile formatting. If you use a document group for your chapter container, you’ll have to use the after-paragraph method, since it will be compiling with the Text/Text separator, which you’ve already set to “Single Return”.

In case that all just got incredibly confusing, I’m attaching a sample project demonstrating a way of doing this. It uses folders for the chapter containers and the Single Return separator between folders and text documents so that I could set the “Chapter 1” prefix to 20pt but the space between that and the chapter header text at only 18pt. It’s set up to compile the first chapter sample correctly and you just need to deselect the “Title” checkbox from the single document Level 1+ row in compile to compile the second chapter sample properly.
ChapterFormatting.zip (111 KB)

Jennifer,

Thank you, thank you! I’m going to tinker with this and see what I can do. I and the cheesecake had excellent holidays – sent my Dad home with about six dinners’ worth of Christmas cheer, plus cheese cake! Now I’m off to a science fiction folk singing conference, aka a filk convention.

You’ve given me much to study and fiddle with.

But I am determined to master this Compiler business if it takes me another six months!

Hope your holidays were also good!

I am adding this question onto my Compiler thread, because it makes it easier for me to keep track of the answers, and to refer back to things.

(Rueful grin) I got sidetracked with some research, some writing, and some dog shows and haven’t yet sorted everything out above.

I’m trying to generate a somewhat rough-and-ready e-book for my co-author of stuff that we are working on and need to refer to.

I’m using a format which has worked for my NaNoWriMo stuff, but it’s generating the folder names as separate chapters, and I don’t understand why.

Here’s the side bar:
2015-07-06aa.JPG

And here is what the “Chapters” are coming out like. Again, it has to be something I’m missing, but I don’t know what I’m doing wrong. (Haven’t gotten any farther with some of the stuff up above in this thread because folders generate as separate chapters.

2015-07-06ab.JPG
2015-07-06ac.JPG

Adding a link to one of my other compiler threads so I can find it again for reference…
http://literatureandlatte.com/forum/viewtopic.php?f=30&t=31600

Anyone? On the message posted 6 July, beginning, "I am adding this question onto my Compiler thread, "

Sorry, saw this briefly but didn’t have a chance to reply and then got side tracked. Could you clarify what you’re trying to achieve?–e.g. should each folder be its own chapter, using the chapter name as the title, and then with all its subdocuments as untitled scenes in the chapter? Should the folder titles never appear either, and it just be numbered chapters?

Re: the format that worked for your NaNo, is this exactly what is described earlier in the thread (so we can look at that for reference), or have you made changes to the compile settings?

It’s been awhile since I touched on this subject. I’m continuing in this thread so that I can easily find all my questions about Compile.

My issue this time is separators.

I have my chapters set up.

I have the sub-documents set up.

I have even managed to figure out the levels so that they come out the way I want them to, more-or-less.

BUT:

Chapter One is centered. It is NOT the 96 points down the page that I wanted it to be. It is at the top of the page.

Then, there are 96 points between Chapter One and the beginning of the text.

I went in and tried to change the separators. I change the separator, and my preset changes from “Roads Split Chapters 02” to Custom. And everything I had in Roads disappears. I change it back, and the preset returns to Roads.

I cannot change ANYTHING in the separators without the preset changing to “Custom.”

VERY annoying.

Pushing this up to see if I get a reply to the message ahead of this one.

Pushing this up to try to get a reply.

I have been fiddling and fiddling and CANNOT GET THIS FREAKING COMPILE TO WORK!

My Chapter Title now has the 96 points before and 18 points after. I got that far.

But the freaking Compile insists on inserting another 96 point before hard return and 18 point after “line” between the Chapter Title and the text.

This is unacceptable. I can’t edit the mobi file and go through and remove that stupid insert from 60 freaking chapters.

I have tried, and tried, and TRIED to change the setting in Compile to “Custom” for separator between Folder and Text, which I figured I would leave blank.

Every time I change anything in the dialog, Scrivener changes the name of my compile from the one I am using to “Custom.” If I change it back to my setting, it changes what I changed back, too.

I can’t EDIT the blasted compile!

PLEASE HELP!

I can’t comment about the detail of what you are trying to achieve here, but simply as regards saving a compile - the way I understand it works is that whenever you make a change to a set of saved compile settings, Scrivener changes the name of the preset in the ‘Format As’ box to ‘custom’ (but this does not change any of the other Compile settings). If you want to keep these settings, with the change you made, then you have to save them again, using the ‘Save Presets’ button. If you want to over-write your existing preset, just enter the same name in the box. Scrivener will warn you before it overwrites.

Yeah; “Custom” just tells you that you’ve deviated from the preset you started from.

I don’t know if this will help, but a feature of the new release earlier today highlights in the binder what documents are affected by each row in the Compile window’s Formatting pane. Make sure your documents are visible in the binder and bring up the “Compile” window. Make sure you can still see your binder (if not, cancel and expand your window to be wide enough to peek out from under the compile window). Then go to the Formatting pane and click on each of the folder, document, and document stack rows there. In the binder, you should see various files and folders highlighted in yellow as you select each “Formatting” row. That tells you if you’re working on the right row to obtain the effect you want.

Maybe that will clarify where you’ve entered an extra set of vertical spacing that you thought would affect the chapter title, but is instead affecting the start of each text document?