Using the trial: the only reason I won't purchase...

I really like this program, it is intuitive, intelligent and not overwhelming, I can focus on writing and the composition feature is really nice.

However, as a great speller and a rapid and imprecise two finger typer, the fact that the autocorrect does not work is a deal breaker for me.

I didn’t realize how much time it saves me now that it’s gone. My mistakes are physical, my fingers get a letter ahead of my mind or visa versa and not having to stop to back up and manually correct is a must for me.
I have a 22,000 word novel in progress I want to finish in Scrivener, but I just won’t make the purchase until the autocorrect is working.

I’ve read all the ‘if you stand upside down and restart your laptop while singing Merry Christmas it works 66% of the time’ tricks and tried them all and none of them have worked, but here’s the thing- I don’t care if one did. I want it to work without some hocus pocus.

Yes, I am running Sierra 10.12.5, I’ve seen it acknowledged as a known bug. Will it be patched soon?

I love the program, but won’t purchase until this is solved.

Regards :slight_smile:

When you say ‘autocorrect doesn’t work’, what do you mean?

The feature does work for most of us, so please describe what:

  1. which version you’re using
  2. what behaviour you’re expecting
  3. what you’re seeing
  4. any steps you’ve taken


I’m having the same issue—autocorrect isn’t working in 3.0.1 (neither was it working in 3.0).

In Preferences, the option to “Correct spelling errors as you type” is checked but misspelled words aren’t highlighted or corrected.

By contrast, “Fix capitalization of sentences” and “Capitalize ‘i’” both work.

I’m on MacOS 10.12.6. Autocorrect worked fine in Scrivener 2.


Please confirm that:

  1. Preferences > Corrections > Autocorrection > Correct spelling errors as you type is ticked

  2. Edit > Spelling & Grammar > Check Spelling while Typing is ticked.

Both need to ticked – the reason is that No 1. sets the default for projects. No 2. allows you to toggle the setting on and off quickly if you need to (cmd-\ is the shortcut), without changing the basic default. (I’m only a user – I think that’s the reason anyway.)

With both those ticked, does it work? It does for me.


That does it—many thanks!


Glad it helped!

Hi, none of those work for me. One of the ‘tricks’ I had referred to was to click and unclick that settings several times and it supposedly would start working, but it never did.

So there is no autocorrect function whatsoever, If I misspell a word it does not underline it in red, when I right click it offers no spelling options, and when I click to spellcheck the entire document it finds no errors.

I am using the version of the trial that I downloaded from this site just a few days ago.
Edit: it says 3.0 (75)

I don’t know that it will fix the issue, but version 3.0.1 was released a couple of days ago and includes fixes for a number of bugs.


Have you tried restarting your Mac?
And does the spell chech work outside Scrivener?

I am having the exact same problem in 3.0.2. No amount of toggling settings will get auto-correct, quote smartening etc. to work.

Rebooting hasn’t helped.

Every other application on my system auto-corrects etc. just fine.

I don’t know if it’s relevant to Scrivener 3* or your circumstances but have you seen this: … own-issues

*In Scriv 3, the Page View toggle is located at View > Text Editing > Show (or Hide) Page View.

Other than that early troubleshooting effort, I’d try booting the OS into Safe Mode, test, then reboot normally and test:

Good Luck.

I know it was said earlier, but do ensure that Edit > Spelling and Grammar > Check Spelling While Typing is ticked. If it isn’t, auto-correction won’t work.

All the best,

Thanks both of those are set as indicated. It started working again mysteriously so perhaps I did the page view switch at some point.

In almost fifteen years on a Mac I’ve never had a problem that required booting into safe mode - can’t imagine it would fix something like this, that’s limited to a single app.

Well this must be the Page View error described above, or something else equally arcane. After using Scrivener for about 6 hours in the last two days with no issues, suddenly spelling and smart quotes stopped working. Restarting Scrivener fixed it. But surely there is some way this can be fixed to prevent it in the future, right?

The linked support article above reads “We are continuing to work on a more permanent solution to this problem” but that was written for Snow Leopard…

I have the same problems using the 3.02 demo.

Have tried all the “solutions” above, plus others I’ve found on the internet, but nothing works. Frustrating x100.

Not buying 3.0 until this is resolved. Not being able to type is a BIG no-no.

I’m sorry to hear you’re having issues with this and that it has discouraged you from purchasing Scrivener. This is frustrating for us, too.

The trouble with this issue is that not a single member of the team has been able to reproduce it in the years that we have had reports of it. Reports started after a macOS upgrade, so presumably some change Apple made had an effect, but even then it was - and remains - only a handful of users reporting the bug, and no one has been able to provide us with any way of reproducing it. We all - myself included - write in Scrivener for many hours each week without seeing this problem.

I managed to reproduce the issue in page view reliably once, but applied a change that fixed it on all test machines for 3.0. But still we receive the occasional report even since that.

So unfortunately, until we are able to reproduce it, or until someone can provide us with steps that cause the problem to occur, there is nothing I can do to resolve it, because there is nothing I have to go on. I have already checked all the relevant code and there is no obvious cause. After all, spell-checking and auto-correction is all handled by Apple’s code; I just switch it on or off. My feeling is that there may be an arcane issue in Apple’s frameworks that is being triggered somehow, but again, I have no way of confirming this hunch: there’s just no way of tracking it down without being able to see the issue for ourselves.

If anyone can find a series of steps that consistently causes spell-checking or smart quotes to stop working, please let me know!

All the best,