Various Issues That Bug Me

I love Scrivener. It’s my new favorite program. But it’s got a few things in it that irritate me and I figure I’d post them here and see if there’s workarounds, or if not, then maybe someone with Da Powah will take note.

First off, when I use Ctrl+A to highlight all and then click the left arrow button, I expect the cursor to go to the top of the selection. In Scrivener, no matter if I go left, right, up or down, it always takes me to the bottom of the screen. I find that somewhat annoying, and I can’t tell if it’s a bug or a setting or what.

I am rather fond of the meta-data, but I would really like a way to change the meta-data for more than one file at a time. I’ve tried clicking on multiple index cards from the corkboard, but when I try to change the meta-data it only changes it for the last one I clicked on. When I’ve got a lot of files, this is less than ideal. I think being able to make mass changes to file information would be highly useful.

The other thing that bugs me, and this is a bigger issue, is the default copy-paste. I can’t alter the actual dimensions of the paper. If I copy-paste into Scrivener and the file I’m pasting from has weird page margins, be they shortened or organized into columns or whatever, Scrivener reflects that with giving me shortened versions of the text, and I can’t change it. Word will let me see the page rulers and change the margins, but I have no idea how to find the margin settings in Scrivener. Moreover, when I copy-paste, I want it to make all of my pastes a uniform font type, size, and keep it all to 1.0 spacing, no double-spacing for me. Ideally it would also retain the italic or bolded font, but this is rather advanced. Right now I’m copying work into Word or Notepad and then into Scrivener, and I’d appreciate being able to cut out the middleman by setting a default paste.

So, basically, when I put text into Scrivener, I don’t want it to have weird settings that interfere with my workflow. I want it to be pure free-flowing text, of a uniform font type, and I want to be able to change the page settings at will. I don’t know if this is just a setting that can be changed, but any workarounds would be appreciated.

Oh, and I forgot to mention. I was saving all my Scrivener files to my desktop, but then I made a Scrivener Projects folder and moved the files to that folder, whereupon Scrivener had a heart attack and didn’t understand that no, I hadn’t deleted the file, I had simply moved it. It wouldn’t save my work to the new location, instead it pitched a fit. I had to put them back, reopen the files, Save As, and put them in the folder I wanted them to be in from the program itself. It wasn’t too annoying - I don’t mind it when my programs have heart attacks as long as I don’t lose any work, and I didn’t - but it was rather silly.

To take care of the copy&paste issue, you can use “Paste and Match Style” which makes it match the settings in Scrivener. The keyboard shortcut is Ctrl+Shift+V. It’s also in the right click menu.

As for the ruler, it’s under Format -> Show Ruler or the keyboard shortcut is Ctrl+Shift+R.

I hope that helps some.

Another option for converting the text after it’s pasted in is to use the Documents > Convert > Formatting to Default Style. This will preserve links and character formatting (and gives you some additional options as well) but will otherwise bring the document into sync with the default formatting set in the Editor tab of Tools > Options… and so should fix your ruler settings for the newly pasted text.

You can change meta-data on multiple items by selecting them in the binder, corkboard, or outliner and then right-clicking and using the Label or Status option in the context menu to change them. You can change checkmark-type meta-data like “include in compile” for multiple items by displaying that column in the outliner (View > Outliner Columns) and selecting the items on the outliner and using Alt-click to check a box in the selection. (With no selection, Alt-click will apply to everything visible on the outliner.)

As for moving the files, this shouldn’t be an issue as long as the projects aren’t open when you move them. It’s true you won’t be able to use the Recent Projects menu to re-open them for the first time, since the file path has changed and Scrivener has no way of knowing where the projects are now stored. (The projects would be removed from this list when Scrivener reopened, but if you moved them and tried to access them via this menu without having closed Scrivener then you would get an error message about the file being moved or deleted.) Just use the regular File > Open or “Open Existing Project” button to navigate to the new location and select the project’s .scrivx file to open it in Scrivener. No need for a Save As copy.

I’ll have to check on the Ctrl+A issue when I’m on a Windows machine. Does the “up” arrow at least take you to the start of the selection?

Thanks, Spitfire, those are both very useful. And thank you Mimetic, that was exactly what I needed to finish fixing my copy-paste problem.

Ah, it was the right-click I was missing. I was trying to use the Inspector itself. I’m not really sure what happened in the moving-files thing, it’s not a problem now, but I included it so that if anyone else had the same problem there would be more data on the issue.

The up arrow takes me to the second-to-last line. Odd, innit?

I have one more question. How do you program new keyboard shortcuts? I think I’m going to be using the Convert to Default Formatting Style option quite often…

It seems to me that the cursor is being moved to the end of the selection, so when you up- right- left- or down-arrow, the cursor moves from that spot. I’ve never noticed this being different in other programs.

Actually, if you want to test it, you can just type a reply in the reply box. It takes me to the beginning or end of the selection depending on which arrow I choose, even here, it’s only Scrivener that’s different.

She’s right. I had never noticed that before, but it’s true. When pressing CTRL-A (to highlight all text), an up arrow or left arrow should place the cursor at the beginning but it does not. I’m running v1.0.3.

I had this issue, and apparently one cannot presently do this in the win version of Scrivener
this is from Ioa at tech support:

That’s what I’m saying, if the menu command does not already have a keyboard shortcut, then you can’t assign a custom keyboard shortcut to it. So you can’t assign a keyboard shortcut to the all capital option since it has no shortcut in vanilla. This is a bug and it will of course be fixed.

Hope that answers your question

This issue also bugs me, but this Alt-Click doesn’t work with Windows and Scrivener I followed your complete instructions MimeticMouton, but when selecting all in the outlier and Alt-Click “Include in compile” only the first item has it’s “Include in compile” option turned off.

This really annoys me, since I have a lot of documents which I don’t want to include in the compiler any more, and I’m not really enthusiastic about clicking this off for every document. :slight_smile: Perhaps there’s a trick that I’m missing?

Today, in another Scrivener project and my biggest project, all document miraculously had their ‘Include in Compile’ setting turned off. Another thing that is strange, is that Project Statistics only counts the documents that have the ‘Include in Compile’ setting turned on, even when I mark the setting ‘Count all documents’, which apparently only counts the documents marked for inclusion.

Is there a way for me not to have manually mark 300+ documents with the ‘Include in Compile’ setting?

(Using Scrivener on Windows 7 Home)

In the compile dialogue, Contents tab, you will see the Include check-boxes; at the bottom of that part of the window, there’s a parenthetical hint: (Alt-click to select or deselect all). That should do it for you.

Alt-click should be working to select or deselect all the compile checkboxes within the outliner, and I just tested this again on 1.2.3 under Win7 and am not seeing a problem with it. The selection bit is wrong; the Alt-click will affect all visible rows, not just the selection, so you could try again without selection though it’s working for me both with and without, so it seems like something else is causing the hitch here.

As roberdguthrie said, Alt-click should also work in the contents pane of Compile to include or exclude all your documents–is that working for you?

Thanks for your helpful suggestions Roberdguthrie and MimeticMouton.

That behaviour, in the Compile window, works indeed fine for me with Scrivener on Windows. Perhaps there is some miscommunication (or misinterpretation from my part) because I was referring to the outlier view.

More specifically, I was referring to the behaviour described by MimeticMouton below that I didn’t succeed with (bold added):

Reading that quote from MimeticMouton again I realised that she meant that one should Alt - Click on the “Include in Compile” column and not the “Include in Compile” meta-data box (that’s in the Inspector).

Alt - Clicking on the “Include in Compile” column does indeed work. Great and thanks for both of your help! My apologies for not reading it well enough. :slight_smile:

Ah, great, glad you got it sorted! Sorry I was not clearer in my earlier description!