version 3 : can't change fonts in prerences/apparence

I’m just trying scrivener version 3.0 before make transition fro version 2.

For me, it seems to have a bug in preferences, for changing appearance/fonts :
as usual, i click within the rectangular area “font”, and now, in version 3, the font menu don’t stay open, so i can’t change fonts.
The font menu is opening under 1 seconde, chen i click on the area “police system 12” (as in the screeshot), and desapear.
I can’t make a screenshot of that because the font menu desapear to fast.

Help please…
(and forget my to bad english…)
Capture d’écran 2017-11-26 à 14.29.48.png


This sounds like this bug:

In which case, it’s fixed for the next update (I hope!).


I think it is different.
I can’t catch the font menu web i click to open it.
I click to open font menu, font menu is opening but doesn’t stay open.
The problem seems to be only in preferences.

I made a test with older version, and its the same.
A problem from sierra?
I jumped from captain to sierra yesterday, and i didn’t have this matter before, with Captain and Scrivener 2…

That is very strange. All Scrivener does is open the font panel - it doesn’t close it again. What happens if you try to open the font panel in other apps? For instance, try opening TextEdit and hit Cmd-T to bring up the font panel - does it stay in place there?

Hello, thank you, you understood exactly the problem :slight_smile:

I just tried with textedit and Cmd-T, all is okay.
So, i tried again with Scrivener3, but in the editor, all is okay.
Then, i tried Cmd-T in preferences : miracle ! it works !

But even doesn’t work with clicking in the spécial area for changing font in preferences…strange…

Anyway, it’s work now with Cmd-T ! ( i didn’t think to try it before you remembered it to me… )

Thank you very very much.