Version 3 - misc. issues + 1 specific Q: setting scroll bar width

Firstly - congratulations! A new version finally brought to fruition thanks to a lot of hard work. Well done!.

These issues do not detract from the achievement IMO. (Win-10 Home, 64-bit 20H2 machine)

  1. Scroll bars, Default theme - in binder, corkboard, document view, etc. (except sub-document list), all vertical scroll bars are half-width. Any fix?
    also affects horizontal scrollbars in e.g. Options… Appearance… Inspector & Notes… in the Colors tab

  2. Change to dark mode and restart and scroll bars look better… but all text in document view is still black against the dark background - but white everywhere else (linsk highlighted yellow; same thing in Grey Matter Dark

  3. Ocean theme - highlighted link (yellow over pale blue??) is illegible. Document text also black but white everywhere else.

When I finally switch back to default the scroll bars are back to the wrong width so there must be a setting for scroll bar width - could someone direct me to it?



I’m sorry, but I can’t recreate any of these issues that you’re reporting.

Everything looks fine for me.

It looks to me more like half of the scrollbar is being covered up by a grey bar, rather than it being technically half-width. I’ve never seen anything like that before, even when running it in some pretty non-standard ways (like Linux).

Are you using any kind of system-wide interface themes, or have you made tweaks to advanced display settings that might be a factor? Could be worth testing in a dummy account with vanilla Windows settings to see if that’s the right avenue to look down.

I logged out and tried a standard user account (i.e. not admin); no change. NB that account had never been used before so was completely vanilla apart from all-user settings/installations.

I rebooted and used the standard user account; no change

(though note: installation was for all users, but the license was not activated for the other a/c on this pc)

Logged in as myself again (no change; none expected)

Display scaling is 100% and the key point is that the scrollbars are only wrong in the default theme, so it was highly unlikely to be any system setting but I tried anyway.

Could the theme have been corrupted? Where is it/could you provide a replacement for the theme alone (I’m not a big fan of uninstall/reinstall when there is no specific reason to suspect a corruption)

Any other ideas?

UPDATE - some time later… machine rebooted with shift key held down… expecting to get to safe mode but in fact it did disk checks and repairs… no change with respect to scroll bars unfortunately (apart from wear and tear on my nerves because it took 20m to boot!)


I really do want to continue working with V3 so I tried to do some theme editing, i.e. start with a theme that does not have defective scroll bars and reset colours etc. until I was back to something closer to the default theme.

I have some observations - I don’t know whether these are reflections of ignorance or issues. Please can you clarify these for me?

  • There seem to be aspects of the UI managed by themes that are not accessible to the user - toolbar, menu background colour for example. Question: is there an option control somewhere for everything that is part of a theme? If not could you possibly provide a “default” coloured theme based on one of the other themes, which don’t have the scroll bar width issue?

  • When I set the background colour of the binder to white, the “lead-in” expand/collapse markers and spaces remained persistently in some colour set by the theme. Question: if you select e.g. Grey Matter Light and set the binder background to white do you see the same effect?

  • Dialog colours are determined by themes too: in Grey Matter Light there are general light grey and darker grey backgrounds in dialogues I would like to get rid of. Even if not all theme elements are currently accessible to users, is it possible to manage dialogue backgrounds etc.
    [attachment=1]Theme coloured dialogue.PNG[/attachment]

Finally, yes in some places it does look as though half a scrollbar has been covered by something else, but in other places there’s just half a scroll bar - it’s as though the target rectangle or clip region is wrong. Two different appearances are illustrated below

[attachment=0]Scroll bar width issue 2.PNG[/attachment]

I wonder if what you are seeing could be a dpi scaling issue between Scrivener 3 and Windows. What are you Windows dpi settings?

In earlier days, with other programs, this was a result of interaction between the video drivers and the Windows OS. My suggestion would be to try looking at things outside of Scrivener, and seeing if there are issues.

One diagnostic would be to roll back to completely vanilla Windows video drivers and see what happens. On the other hand, the issue might be that you’re not actually running a graphics card that can handle the resolutions you’re set up for…

One-off issues like this usually aren’t in the program, they’re in the OS and the hardware. If nobody else has this issue, it’s not Scrivener, it’s your system interacting with Scrivener.

Thanks everyone for the input, let’s see if we can clarify a few things…

The system setup is Win 10 Home 64-bit, Build 20H2 - a detailed system report is now attached. The screen scaling is 100%.

The scroll bar issue is the same whether the window is on the motherboard Intel graphics or on the nVidia graphics card. (for which the driver is also up to date).

Whether or not the scroll bar is good or not depends on the theme. All themes other than Default are perfectly OK.

No other program - and I have quite a diverse selection of common and uncommon apps - shows or has ever shown any thing like this - including Scrivener 1.9.

None of the hypotheses offered accounts for all the evidence. In particular, I find it hard to see how any system issue could affect one theme and not another and still be a “system” issue rather than an application issue. If scroll bars work in any theme then it can’t be a system problem with Scrivener’s scroll bars as such.

Yes, of course it is Scrivener “interacting” with my particular system, but - and especially since this software is a brand new release - all the evidence points to an issue with Scrivener; it may be an obscure issue but the balance of probabilities very strongly favours that hypothesis.

I expect it will be sorted soon, but the underlying issue is obviously not obvious! :slight_smile:

Julian, do you know if you have any other apps or programs that use Qt?

I wonder if this isn’t related to some of the strangenesses that the Beta was having with the latest version of that.

@takirks - can you clarify the Qt reference? The only Qt I knew of was QuickTime… but now, if you meant I can confidently say no, that is not installed on my system.

They are referring to Qt, the development toolkit used to create Scrivener. It may be difficult to compare though, as other programs using it may not have customised the look to the same degree we have (or in the same way). There is at any rate a list on Wikipedia. I have no idea how accurate that list is though (seeing as how we aren’t on it).

I did have another thought, is this problem showing up in all projects, even one created from scratch in v3? If not, I wonder if holding down Alt and clicking on the File menu, to reveal the special command that will close the project and clear its interface settings, might be worth trying. Note you can save your current layout settings via Window ▸ Layouts ▸ Manage Layouts… so as to not lose a bunch of layout settings.

I created another project anyway. I chose a project of a different type (non-fiction) and the issue was the same, but i tried clearing the UI settings anyway; again no change.

Thanks to the Wikipedia list I can confirm I have or have had other software that uses Qt
Foxit Reader (uninstalled)
MuseScore - no scroll bar issues
Spotify - no scroll bar issues
Wolfram Mathematica - no scroll bar issues
Calibre version 4.23.0 - YES! Exactly the same issue! (and no change after update to latest 5.14)

[attachment=0]Scroll bar width issue also in Calibre.PNG[/attachment]
I hope this this helps!

NB this is very old but does this shed any light on the matter? Similar issue described

I see the same problem in the Calibre screenshot. Most likely you have some Windows default setting which spoils the scrollbar sizes with Qt. This happens only with the default Scrivener theme, as it is the only one using Windows defaults. The other Scrivener themes use specific settings and not Windows defaults.
The fact that you get the identical bug in two different independent applications, speaks that it is either a setting on your Window OS or a problem with the Qt library. I will check for a bug report with Qt. Still I would suggest checking some Windows scrollbar changes you might have done via Windows custom themes and settings.

Re Windows scroll bar settings etc. Great suggestions… I know I use Winaero Tweaker so I checked, and reset

and checked in the registry here Computer\HKEY_CURRENT_USER\Control Panel\Desktop\WindowMetrics and the ScrollHeight and ScrollWidth are both the default value of -255.

The issue is still present in Scrivener and Calibre (but not and never was in e.g. Mathematica in notebooks, palettes, or dialogs)

(Are there any other dependencies on e.g. Window Border width and Border padding (current values are 1, 4 respectively.

And, I do have a custom theme that might be based on the Aero Lite theme… .theme file content at the end (despite the subsequent failure of theme change to have any effect - just in case). However, I reset the theme to windows default (without reboot) and the issue was not resolved (custom theme now restored)

Here’s hoping it’s a Qt issue… though, since other themes use non-standard scroll bar parameters, you could also set scroll bar parameters explicitly in the default theme too - to the nominal default values. :slight_smile:

Thx, Julian

**** .theme file ****

; Copyright © Microsoft Corp.

DisplayName=Julian’s Teal Theme

; Computer - SHIDI_SERVER




[Control Panel\Cursors]
DefaultValue=Windows Default

[Control Panel\Desktop]
Wallpaper1=%USERPROFILE%\desktop\spotlight stuff\lockscreen images by winaero tweaker\landscape\lockscreen_63d56cc50390c2f83c35af3a485900f80776da26d99fd0fb05e32795534d04d8.jpg
Wallpaper2=%USERPROFILE%\Desktop\Spotlight Stuff\LockScreen Images by Winaero Tweaker\Landscape\LockScreen_761bc2130ab3ae4a21a94e51418392d364520b81f0c4adfbcbca14a1b781414a.jpg
Wallpaper3=%USERPROFILE%\desktop\spotlight stuff\lockscreen images by winaero tweaker\landscape\lockscreen_2adeabd098a7d94bb111c91b6328e35da103f966b13b13c5a75360a464e3fb72.jpg





I HAVE DISCOVERED THE CAUSE… it is Windows 10… the question will be how to resolve.

Something about this issue reminded me of an equally obscure issue to do with a Pen Tablet and GIMP.

TL;DR there is deep issue in Win 10 relating to the handling of high DPI devices generally. I have a 4k TV connected to my nVidia graphics card.

TV plugged in: scroll bars are half missing. Unplug TV and scroll bars are correct. When the TV is plugged in, the scaling is set to 225% (+ fix scaling for apps On). (Unplugging the TV also fixed the pen tablet & GIMP issue, but I found a better resolution)

The problem is that something very low level is affected by that scaling value even if the app concerned does not have a window on that device.

The previous Pen Tablet & GIMP issue was resolved by changing the High DPI settings for GIMP via program compatibility,

Ergo, I have solved the problem and offer the following settings for anyone else who may encounter them. These settings are also good for Calibre ;)

[attachment=0]Scroll bar fix via compatibility settings.PNG[/attachment]

(This is what you might call an edge case… if not a corner case :smiley: )

Thanks for posting the solution!

Oh, interesting. There was a thread in the Windows Beta that also involved some display issues at 225% scaling…

Hopefully the fix for the scroll bar issue might also resolve other issues related to Windows scaling.