Very Slow on spellcheck..... after recent update?

I am finally surrendering to post that I have been having the spinning rainbow wheel of death a LOT since the update to the iOS enabled update of Scrivener for Mac (or possibly since my Sierra update, which happened at a similar time). I write in full screen (distraction free) mode, with auto-correct enabled. Used to be that autocorrect would happen so fast I often didn’t notice it, and when I had a very strange word it would be immediately underlined in red. Not so any more. Very often a whole bunch of typos will go unflagged while I am typing. If I then click on an obviously misspelled word (hwere, for example), I get the spinning rainbow wheel. Sometimes, after a LONG time, all the errant words will suddenly get underlined in red (often simple mistakes that would have been auto-corrected in the zippier past). I have tried uninstalling and reinstalling Scrivener. Disabling all background programs, like Google Drive. I am now doing a complete HDD wipe and clean reinstall of Sierra, just in case.

I’m wondering: is it possible that my MacBook Air, with only 4G of ram, is not able to handle the demands of the reconfigured Scrivener? Are there any other suggestions that I haven’t tried?

I’m so used to Scrivener just working that I can’t bear to watch that little wheel spin and spin, and it’s driving me crazy that I can’t fix it. :confused:

I have no trouble running Scrivener on a late 2010 MBA with only 2GB of RAM and Sierra 10.12.3 installed. But I have never used spell check. Spell-check is provided by the system, and I think there are other threads in these forums which suggest that spell-check under Sierra is somewhat inconsistent to say the least.

Ioa (AmberV) will know more about it than me, but it’s not a lack of RAM that is causing your problem.



Thank you for the reality check! I hope there is a solution, since I have used it without difficulty in the past. :frowning:

I’ve had a similar problem since upgrading to Sierra, but it’s intermittent, and goes away after a restart. Until it reappears. It also seems exacerbated by Full Screen, which I gave up on. Instead, I just stretch the window to almost full screen, and call it good. When I upgraded to the newest version of Scrivener, it didn’t change a thing, which leads me to believe it’s Sierra-related. (It might have something to do with the 32-bit vs 64-bit bidness, which Keith is correcting with the new paid v3.0, due out, I surmise, sometime before the anniversary of Wellington’s victory at Waterloo.)

Now, when I open the WIP in the early AM, I let Scrivener sit and think about its job while I make the coffee, and when I get back, ready to work and caffeinate, and don’t see any red squiggles beneath misspelled words, or the Dictionary doesn’t load with a two-finger press, or drag&drop develops a 10-second delay before the cursor changes to an arrow, I close the program, restart the computer, and everything is working nicely before the cup is three gulps down from its plimsoll.

What you describe is exactly what I experience-- much slower when I am in full screen mode, and also after I have been working awhile in Scrivener (over a period of days) without rebooting. Rebooting clears it up, somewhat. Reinstalling Scrivener cleared it up for awhile. And my recent, pointless reinstall of Sierra made it better, but no better than rebooting. Always, after some time, I get that spinning wheel again.

I’m afraid it must be related to Sierra, and/or some poor communication between Sierra spellcheck and Scrivener. I appreciated your patient, process-oriented approach to the whole thing. I am going to try and adopt a similar attitude-- wait for my spellcheck the way I might wait for a taxi, way out in the country, on unmapped roads. The point is the writing, after all.

Or you could just restart.

Yes, of course, but in my case the restart doesn’t speed things up for too long. Your “make coffee” mindset might help me quiet the ongoing battle to “fix” this. :wink: