View gone funny

I was using a view in MacOS that worked for my increasingly bad sight, but it gave various problems. My son kindly reset it to default, but the result is that Scrivener pages now have huge gaps beside them (see picture, if I succeed in attaching it). How can I re-educate Scrivener to have normal… margins? Whatever this is?


Screenshot attached

You have the Fixed Width Editor option enabled. To change this you would go into Scrivener sEttings/Preferences and either uncheck that option or adjust the fixed width setting to suit you better.

But I would like to suggest two things:

  1. Reading over very long lines is hard on your eyes, so really you should not disable this setting unless you increase the visual scale of your font (see below). You will sometimes see a recommended text block width of 60 characters as a kind of ideal. The text block in your example is already at 90. Widening it further will definitely be less than ideal for your eyes.

  2. For ease in reading, the best thing to do is increase the zoom setting on the Scrivener editor pane. I have my default font set to 12pts, but I keep have the zoom setting in the editor pane set to 175%. This makes the text visually sizeable without changing the font size of my text. That setting is right at the bottom of the editor pane. Highly recommended!

1 Like

Hm. I tried upping it to 175% and reeled back, blinded. Set it up to 130% and opened the Inspector pane, which makes it less glaring. Thank you.

Haha. Whatever suits you. (I see you have your text set to 14pts, so yeah 175% might be a bit much.)

If the white space to the side of the editor pane when the window is wide is too glaring, you might want to tone down the Fixed Width Background color (which you have set to White). This setting is found in the same basic place as the other I pointed to, namely Scriv Settings > Appearance > Main Editor but pick the Colors tab then and tap the color swatch under Fixed Width Background. A slider enables you to just grey it down a bit.

Thank you, I’ll do that!

Hm. Tried. The slider didn’t seem to do anything. I tried all the slides from white to black and none made a tither of difference.

Hmm. Are you and I talking about the same thing? The background color actually adjusts live as you work the slider or color wheel.

To be clear, what we are adjusting is the fallow area to the right and left of text area when Fixed Width Editor is enabled (and the window is open wider then the fixed-width setting). If perchance you disabled the fixed width editor, then there is no gully to tint. Or maybe your window is not so wide as to make the Editor pane wider than your fixed-width setting, so you are not seeing the gully.

(You can also adjust the tint of the “paper” behind your text, if that is what you thought you were wanting to do instead.)

Suddenly it worked this time. Weird!

If you already had the color picker open for any reason when yu tried at first, that would explain the first attempt not working. The color picker panel does not seem re-purposable after it is opened.

Glad you got it sorted.