View > Inspect > Comments & Footnotes Keyboard Shortcut

The menu shows the keyboard shortcut Control + Option + Command + L in View > Inspect > Comments and Footnotes to display the Comments & Footnotes section in the Inspector. This keyboard shortcut does not have any effect for me however, and the desired section is not selected (clicking the menu entry works, however).

I am running Scrivener 2.7 on OS X 10.11.1, my language is set to US English. I checked my settings and could not find any other system-wide keyboard shortcut on the same key combination that might take precedence over the Scrivener binding.

I also found out that the Control + Option + Command + L binding is not listed in the User Manual and the old binding was Control + Option + Command + K, which is now used for View > Inspect > Snapshots. I would speculate that you forgot to “rewire” the shortcuts after the introduction of the new Custom Metadata section in the inspector (and the User Manual is not updated yet).

Observed Behaviour:

  • Control + Option + Command + L does nothing

Desired Behaviour:

  • Control + Option + Command + L does select the Comments & Footnotes section in the Inspector
  • User Manual lists the correct keyboard shortcuts on page 466

Thanks for the note on the manual, I have fixed the missing entry in the appendix that you referred to. The M key is used for custom meta-data, K for snapshots, and L for footnotes and comments. That is how it should be, and how it has been for years, so yeah there must be something odd with your configuration—I just double-checked and it is all working fine for me (for both panel selection and keyboard focus) with the same version numbers you’re using.

Does the shortcut show up correctly in the View/Inspect/ sub-menu?

Thanks for your help Ioa. I looked again and found the culprit: 1Password has set the default global shortcut for locking a vault to Ctrl+Opt+Cmd+L and it somehow slipped my mind in the first round.