Web archives edited in Together not working?

Hello,

I am evaluating Scrivener and found one problem with Together. When I save a selected text from Safari as web archive to Together and edit it (even add one letter and save) and drag the file to Scriviner it doesn’t preview the web archive anymore but just says “Loading web archive…” and nothing happens.

If I drag web archive from Together which I haven’t edited it Scrivener shows it just right.

Any ideas please?

Using Scrivener 1.11, Safari 3.1.1, Together 2.1.1 and Mac OS X 10.5.2.

Thanks for any help.

Just as an FYI. I am on same software setup and can recreate the issue. Unmodified web archives dragged and dropped from Together import without problem; modified ones don’t. Just as a comparison I did the same test in DTPro. Results: Scrivener imported both the unmodified and the modified file, however, the modified file did not reflect the text change. But dragging and dropping the modified file from DTPro to the desktop and then importing that file into Scrivener worked fine, with the text change intact. Going back to Togther and repeating the program to desktop to Scrivener process, however, resulted in the original problem. Scrivener could still not import the modified web archive file from Together. My guess is that the issue probably lies with Together, although I found the DTPro direct to Scrivener result (i.e. imported file, but not with the changed text) interesting, too.

For what it’s worth. :confused:

Thanks for the information, JRP. Good to know. Hope there is a change in the future so edited web archives would get imported to Scrivener, maybe before I have to make the choice of keeping Scrivener or not :slight_smile: Hoping the best!

Glad the research was of some use. Have to say that as a longtime user of both Scrivener and Together, if if came down to it I would keep Scrivener and drop Together if importing web archives figured prominently in my workflow. Other (although not nearly as good) alternatives exist to Together; none exist for Scrivener. :smiley:

I’ll take a look at this when I get chance (before the next update), but the next update won’t be out for a little while I’m afraid. Of course, it is possible that the problem lies with Together. Scrivener loads web archives using the WebKit. Can Safari open these web archives?

I’m afraid I can’t hurry the development process just because someone threatens to drop Scrivener, though. :slight_smile:

Best,
Keith

Okay, I just checked this and I cannot reproduce it. I imported Together’s home page into Together, edited it, saved it, exported it and imported it into Scrivener and it loaded fine. So I need more info:

  • What OS are you using (10.4.11, 10.5.2 etc)?
  • Which web pages are you having problems with?

Exact steps will really help.

Thanks,
Keith

Thanks for your information! Even if a program has few misfunctions it’s always great to see personal comments from developers rather than just post from customer support who usually are no help.

I checked your suggestion and Safari did open all good and right web archive edited in Together.

I am actually not a writer myself but I have assigments where some writing is needed every now and then and Scrivener seems interesting, maybe not perfect on smaller and quicker writing projects but we’ll see. Having all research information together with writing task is anyway quite nice even though it’s never too stupid to just keep all related files in same folder dedicated to specific project.

I’m going for a longer trip to South America soon and it is interesting to see if I could implement blogging and private diary somehow to my workflow during the trip. Maybe it’s not helping with blogging at all, I don’t know, I haven’t keep up any blogs before.

I already bought Journler and Togehter and those are great apps from independent developers so I have good experiences about small software producers already. And Things seem to stick as my task management system and buying it when it comes commercial. So if those apps come work nicely with Scrivener I’ll be very happy!

That’s strange. I saw your second post and now if I use the same page, reinventedsoftware.com, import it to Together, edit it and dragged to Scrivener I it doesn’t work and just says “Loading web archive…” in preview window.

So for your question which web pages I would have to say all which I have edited in Together.

I am using Mac OS X 10.5.2, Scrivener 1.11, Safari 3.1.1 and Together 2.1.1. It’s actually said in the first post :slight_smile:

If there’s something I could do, please let me know.

Ah, I’ve reproduced it. I missed the fact that it only happens when you create a web archive from the selection, which you mentioned in your first post. I’m not sure what is causing it yet, but now that I can reproduce it, I should be able to see where the problem lies.

Scrivener was never really intended for small projects (or blogging). Mind you, my partner uses it for small journalism articles, where she needs to keep a contact list together with her article and the occasional reference material.

All the best,
Keith

Great news, thanks Keith. Resolving that would definitely make worth to my workflow so I keep my fingers crossed.

I haven’t yet checked how Scrivener would bend for writing my small reports and news for one web site so that all previous writing, research and references for this site would stay in same project file to keep my writing coherent.

Cheers!