Web URL Links Not Working

Hello, I’m a new user to Scrivener, but I do think this may be a bug. Whenever I copy a YouTube link (either from the address bar or from the “share” section), and then use it to create a link in Scrivener, it doesn’t work properly. So, I’m highlighting words, using “Add Link…” but when I click on it, the colon is removed from the URL so that it doesn’t open properly in my browser. I switched by default browser from Safari to Chrome and it’s still not working. When I go to edit the link, the : is there (https://) but when it gets to the browser URL header, it looks like (https//) and so I have to go in and add the colon manually for the web page to open. This is consistent with my different links.

Thanks

Are you creating your https:// links with an additional prefix, like “http://”? If so that won’t work so well, as the link will be “http://https//blahblah”. For secure links you are supplying your own prefix, so try using the “no prefix” option.

Thanks for the reply. It’s an inconsistent issue. Some have http before and some don’t but that doesn’t seem to matter so I’m not sure about it. I tried to find the “No Prefix” setting in the preferences without luck. Where is it?

The main factor I’ve isolated is that sometimes when I have the . address it loads okay, and other times, it’s tries to load but fails, and when I check the URL address bar, it dropped the colon.

It’s not a preference, since that’s the kind of thing that is likely to change from one URL to the next. It’s an option directly within the Edit/Add Link… sheet.

This just happened for me. I copied a URL from the web browser and used it in Scrivener. I did not edit the URL. The URL appears to be correct in Scrivener, but it removes the : before it opens in the web browser, so it fails to open when clicked on. Manually adding the : results in the page loading. The bug is in Scrivener. It seems to strip the https: and append the http without a :. Doubly bad.

Do you have an example I can use to look into, along with the procedure you are using to insert the hyperlink and how you are verifying it is correct in Scrivener?

I navigated to github.com/mrlegowatch/RolePlayingCore in my web browser. I copied the URL. In Scrivener, I selected Add Link, and pasted the URL into the text field. I did not edit the URL. Then I clicked on the URL in Scrivener. It opened https//github.com/mrlegowatch/RolePlayingCore which is missing a : and fails to open. It appears from the UI that it expects an http, not an https (which is a bad thing to expect in 2017), and it also maybe expects not to have https already in the pasted text?

Okay, unless you are setting the URL to “no prefix”, this is just exactly what I was referring to in the second post above.

It sounds like your browser is unfortunately obscuring the full URL from you, so you aren’t seeing the “http://” in front of “https//” (which is rightly getting the invalid character stripped out of it by Scrivener).