Weird automatic substitution

Every time I write three dots in sequence it is automatically changed, from … to … , i.e. one character with three dots tightly together. I have checked the manual, searched in here, but none of the tips gives any clue as to how to get rid of this.

Auto-correction of spelling is Off in both Scrivener Preferences and in Yosemite System preferences.


And then suddenly some trial and error solved it …

It appears that in Preferences -> Corrections, “Replace double hyphens with em-dashes” not only control hyphens/dashes but also “three dots in sequence”. By unchecking “Replace double hyphens…” also result in an invisible unchecking of “Replace three consecutive dots …”. Weird!

It would have saved a lot of frustration if this had been mentioned somewhere. It also appears that it has to be deselected in the App you are currently working in, as there does not seem to be any system wide selection/deselection of this in Yosemite System Preferences.


have you tried to open Scrivener Preferences>Auto-Corrections, and, under Substitutions: un-click “Replace triple periods with ellipses”? (Ellipses being the name of the graphic three-period symbol)

See that problem already solved. Good.

Thanks for the tip. However, the “replace triple periods…” was already un-clicked, thereof my frustration. How was I to know that handling of double dashes would also affect handling of triple periods? :open_mouth:

Well, something new learnt. That’s can’t be bad. :smiley:

Yeah, that’s a bit unfortunate, but it’s just how Apple decided to do things, and our checkboxes are just using the Mac’s substitution engine. For whatever reason, they have decided to conflate em-dashes with ellipses a few releases back, which is why the dashes checkbox impacts both. This will be cleared up in the future. Although we can’t really remove Apple’s underlying weirdness, it will be the options that change to better reflect what is going on.

Thanks for the explanation. I think I found a work-around fix for Mac users who want three periods and em dashes.

First, copy an em dash onto your clipboard.

Then, open your OS system preferences > keyboard > text and click the + symbol to add a new auto substitution. Enter two dashes in the first “Replace” column, and paste the em dash into the second “With” column.

Now, even though Scrivener preferences aren’t set to automatically change it to an em dash, your system will by default. (Works for me using Yosemite.)