Weird copy+paste from .ODT

Dealing in poetry, here.
So, I set up a Scrivener for the 30+ poems I’m writing this month, and yesterday I built an OpenOffice file for poetry forms (villanelle, roundel, etc.), and today I thought: It would be much more convenient if that was in my Scrivener file instead! So I tried to import it whole-cloth to Research, just to see if it would work. It didn’t, it gave me a blank screen that couldn’t be edited.
So I trashed that, went to OpenOffice and copied all the text and opened a new page in Research, and tried to paste it all in. There are six forms so far in my Poetry Form document. The first one pasted in fine (with a couple formatting sillinesses, like indents where there hadn’t been any), and the first few lines of the second one pasted in, with Times New Roman changed to Verdana but only on the last couple words.
So, I fixed all the formatting, went back to OO, and copied everything that hadn’t pasted before, and tried it again. Much the same thing happened: I got the rest of the second one, and all of the third and fourth, and then just a line from the fifth, which halfway through changed to Verdana (which had been my default font, but I changed it to Palatino Linotype before pasting anything in, while the .odt was in Times New Roman). The indenting was there, but this time I ignored it.
I copied the last bit starting with the beginning of the font-changed line, then highlighted the font-changed line and tried to paste over it. It acted as though I had successfully pasted something (the highlighting blinked out), but the line remained unchanged.

I tried deleting the Rondel info (title and one font-changed line) and starting completely over, and it just gave me the same two lines. So I then tried starting from the end of the font-changed line; and I got about nine words or so extra, with font-changes halfway through. So I suppose I can eventually get the rest of my poetry forms into the document, nine or ten words at a time. (I suppose the next step for me is to change it to RTF and see if that’s better?)

Instead, I fixed the formatting issues in the Scrivener page, and then tried pasting again (just from the end of what I already had), and it all showed up, but with line-spacing issues. (It’s 1.0, but with .6 pt after a line.)
So, I’ll fix the formatting again, and be a happy camper (and be able to get on with my writing, but it’s a thing. Should we just know to always convert everything to RTF before copy+pasting?

Also, is there a way to make the default font (when a new file opens) what I want it to be?