Weird printing

Documents look fine in Scrivener, taking up the whole page - but when I print them, they leave giant margins on each side and at the bottom of the page. Why? What? How can I stop this? (I have the view set to 150% so I can see it.)

Anyone?

Printing directly from Scrivener (without compiling)?

  1. File > Page Setup > check the paper size being printed to.

  2. On the same panel, click Page Attributes > Scrivener > check the margins.

Slàinte mhòr.

Page Setup is for A4, which is correct. Is that Margins screenshot part of the same dialogue? I can’t seem to find it.

I can’t find a way to look at the margins other than in the Preferences, where they look like this:

Screen Shot 2018-08-22 at 20.34.56.png

Oh, wait, changed the Attributes menu in that Page Setup box to Scrivener and margins appeared. They look ok, though:

Screen Shot 2018-08-22 at 20.40.39.png

If the page size and margins are all good, the printed text should extend to the page margins.

Is it possible that the text is in a cell or table that is restricting its output width?

Slàinte mhòr.

Hm, maybe, it’s not happening with another item from another project that I tried.

How would I see if this is so? On the screen, it looks absolutely normal.

If you select all of the text in the editor and then create a new text item for testing, and paste into that using Paste and Match Style, does the problem persist? It could be the text has some indent formatting or as suggested table formatting that is altering how it appears on output, but in such a way that the editor itself isn’t making that obvious (maybe if the editor is narrower than the actual print page width).

No, it prints in the same weird way.

I selected all, then used cmd-alt-shift-v to paste it without formatting into the new empty document I called Test.

Since it printed with these strange margins, I tried doing the same with another document from the same project. I created another empty document and called it Test 2. Printing a page of that had the same result.

So it must be a setting within this project.

I can’t see any way to choose A4 in the print settings; tried changing from Last Used Settings to Default Settings but it still does the same business of printing with huge margins.

Okay yeah, definitely sounds like the print settings for that project then. The A4 setting is in File ▸ Page Setup…, in the main “Page Attributes” section, between Format for (printer) and Orientation. If you don’t see A4 in the Paper Size setting area then I don’t know what’s going on there—I think the printer driver supplies those settings, but I can’t imagine a printer manufacturer would leave A4 off the list!

Went back into that Page Setup, which I’d looked at before, and noticed that it was set for “Any printer”. Changed it to my old HP laser printer and chose A4, and bingo! - we’re in business. It’s re-educated to print properly. Thanks very much.

Glad you managed to get it to work with Ioa’s help.

Slàinte mhòr.

With both of your help! Sláinte mhaith leatsa