Weird Symbols in place of Apostrophise[BUG LOGGED]

Originally posted this is the Mac Bug Hunt section but as I’ve been using both Mac and Windows versions of Scrivener I’ve been advised to post here as well, so here it is!


I’ll be honest outright and admit that I’m not entirely sure if this is a problem only in 2.0 on the Mac or whether this has been created by trying to use 2.0 and the Windows version of Scrivener together, but I’ll try and explain as best I can and hopefully it will help.

I tried searching first, the exact error I’m getting can’t be searched:

I searched on apostrophes, came across this but I don’t think it’s the same thing, as this appears to have occurred as a result of importing, whereas I’ve come across with items that were made within Scrivener viewtopic.php?f=3&t=1769&hilit=apostrophes

Anyway, I’m getting a problem with the apostrophes within the index cards in my NaNo project. Unfortunately, I can’t tell you when the problem occurred, because I only noticed it today. Basically what’s happened is some of the apostrophes have changed to the code ‘ like so:

Sometimes clicking into the particular card corrects the problem, sometimes it doesn’t, but the problem reappears once the document is reopened. If I manually change each one of the problem symbols, it doesn’t reoccur.

I tried a project find & replace, but it doesn’t work.

I can send the .scriv file if it will jelp, just lemme know.

I’m writing in English and I’m using the default fonts. Text within the scrivenings themselves seems unaffected; it’s only happening on the index cards. The problem still occurs if I change to the “small font size”

I am using a MacBook Pro with OSX 10.6.4 and Scrivener 2.0 - I also briefly used the Windows version on this document, for which I both used the initial release executable and the revised one released on 29th October, which may or may not have contributed to the problem.


Thanks!

Looks like a character encoding problem. What kind of format did you import? Plain text (.txt) or html? If yes:
can you open the file in an editor and find out what kind of character encoding it is?

Best Regards,

Markus

Hi Markus,

That’s just the thing; I haven’t imported this, these are just index cards built up in an empty Scrivener document. As I mentioned previously, the only thing I can think of is that I have used both the Mac and the Windows Beta version of the program together; maybe something has ‘failed’ between the communication?

Update on this: looking in the coding, the ones that are converting to the strange symbol are ’ whereas the ones that are unaffected are ’ (I honestly have no idea if they come across any differently; I realise they look the same, but they appear differently within the document!).

Thanks. I think I know what’s causing this. I have logged a bug for it and I’ll fix it.