What in the world is up with .mobi?

I can no longer compile .mobi through Scrivener. It may be only coincidental, but it began probably on the current build of Scrivener.

It throws an error (or more accurately, tons of errors).

I have tried this on a new M1 MB Pro running Big Sur (-prise!) v1.1 and a 10-yr-old MBA still running Sierra. I’ve tried it with files not touched for months which compiled fine a while back, and ones edited today.

I did get a series of docs inside a chapter folder to compile. But the chapter folder itself would not compile if there were anything in it. I removed all text from the folder and it compiled. Then I added a single period in Helvetica 18pt, and it threw an error.

I guess this could be related to Kindle Previewer 3, but who really knows? I had v3.41 on the old MBA, which has been there for a while. I downloaded the current version on the M1 MB Pro which is v3.5, but neither seem to be of any help. Actually, it seems odd that Scrivener requires KP3 at all to compile, but I imagine that’s some silly Amazon hoop they have to jump through.

I know Amazon is scrambling, and that .mobi is a dead format walking, but what this means is that while a Kindle can handle many different forms of files, quite ironically it can’t compile a Scrivener file for beta readers who want to read it on their Kindle, using the same exact file format the Kindle was designed to use and has embraced since forever.

Oh, I know! I’ll just go ask Alexa! (yeah, right)

Are there workarounds? It doesn’t seem that Kindles accept .epub, either.

Scrivener does not create mobi files directly, but invokes (previously) KindleGen or (now) Kindle Previewer.

Kindles may not accept epub files, but Kindle Previewer does. If you’re not able to compile directly to mobi format, compile to epub and open the result in Kindle Previewer.