What the )*&^%*&%(* ?????

I have updated - tho handled so poorly by the code – to 1/9/6…

But I’m now trying to put together a Boxset of 3 books, two of which were written in 1.9.5

When I put the oldest one “in” the new Scrivner – it continues to say that it’s 1.9.5…would I like to update to 1.9.6. Said both NO and then YES…made no diff.

When I try to compile, using the preset I saved from previous boxsets - it will not get passed this error notice…


Amazon kindlegen(Windows) V2.9 build 1029-0897292
A command line e-book compiler
Copyright Amazon.com and its Affiliates 2014


Info(prcgen):I1047: Added metadata dc:Title “BoxSet Two”

Info(prcgen):I1047: Added metadata dc:Date “2016-08-22”

Info(prcgen):I1047: Added metadata dc:Creator “Jim Rudnick”

Info(prcgen):I1047: Added metadata dc:Publisher “RUDNICK PRESS”

Info(prcgen):I1047: Added metadata dc:Contributor “Scrivener for Windows (1.9.5.0) [literatureandlatte.com/scrivenerforwindows/]”

Info(prcgen):I1047: Added metadata dc:Rights “All rights reserved.”

Info(prcgen):I1002: Parsing files 0000048


Could someone - anyone tell me what the heck is wrong? I’ve tried this every single way I could…but never gets pas the 00000048 thingy…

Help here please?

Jim

No one else has run into this?

No one else making a box set has seen this not compile?

:frowning:

It seems to be a project specific issue from what you describe. Have you tried emailing tech support?

I can try and see if I can replicate your issue. How is your binder structured?

Considering a “box set” is involved, roughly how many words would you estimate to be in the entire trilogy? I’m wondering if maybe kindlegen is running out of memory or something. Compiling in smaller chunks as a diagnostic step to ascertain whether less content, configuration otherwise identical, will successfully compile, is what I’d do.

Yes, I have emailed tech support…hoping that there might be an answer…

StaceyUK – my binder is as you can see here –

Three books all properly placed in 3 major folders–each with Chapter subfolders and then scenes. Normal…I’d say?

AmberV – the three books add up to about 197,000 words…not a lot I’d think for a 3 novel BoxSet…and memory on this laptop is huge with 16 GB of RAM…not a problem I’d think…

???

HELLO SUPPORT…

HELLO?

NO CONTACT IN TWO DAYS…AND MY BOOK CAN’T BE PUBLISHED TILL SCRIV CAN COMPILE SAME…

HELP HERE PLEASE…

You are compiling kindle output, for Amazon…?

Hi JVRudnick,

I haven’t used KindleGen or the Scrivener compiler much, so don’t have any specific suggestions for you there.

But have you tried AmberV’s suggestion of compiling in smaller chunks as a diagnostic step? In other words, confirm that each book can compile separately in 1.9.6, then perhaps compile smaller combinations of books. (Book1 + Book2, Book2 + Book3, Book1 + Book3).

At least that would provide a clue if it turns out that a particular book or combination of books is causing the problem.

Best of luck to you,
Jim

If publishing via Amazon, an alternative approach is to compile in some other format - epub, html, … - and then let Amazon’s Kindle Direct Publishing create rhe kindle book.

Yes…thanks…one and all…

But I’ve tried to compile to ANYTHING else…always the same answer…WILL NOT COMPILE past the above noted error…

So no can do…

Maybe tho, as SUPPORT here is lacking, I’ll try to de-tune the 3 book boxset to 1, then try and if that works add them back 1 by 1…sigh…

:frowning:

So you are getting some kind of similar dialogue about errors if you compile to epub?

I’d split the in order to locate what it is that causes the error.

The error message you shared is produced by kindlegen itself. Scrivener captures the error data and puts it in a window so you can easily review it. If you compile to ePub or PDF you won’t be using Kindle converters, and it should in theory be 100% impossible to see this error message, because once again, Scrivener isn’t generating it.

What I would do is generate an ePub and then feed that to the kindlegen binary directly on the shell and see what happens, or if you aren’t sure how to do that, you can use Kindle Previewer to open the ePub, as it has its own kindlegen built-in.

As to support, I asked you about a diagnostic step two days ago, which you refused to even try for some reason. I mean I guess I could have asked again 24 hours later? :slight_smile: