When compiling to PDF, cuts off after specific page

Hello all,

I’m trying to compile my project to a PDF so I can share it with readers. However, when using my modified compile format, it cuts off after page 289. If I use Scrivener’s standard format, it shows all pages. And, if I use my format but export to Word, it also shows every page. It’s only when I export to PDF that it gets cut off.

To add to this, if I uncheck the Widows/Orphans feature, it exports every page. However, I’m left with widows and orphans. I tried changing the margins to see if Scrivener was cutting it off after a specific page amount, but it still got cut off, only earlier in the final chapter. So it seems that either my modified compile is cutting it off after a specific page amount or a specific word amount.

This is all very odd. I could use the standard compile, but it doesn’t get it the way I want (I have section titles within chapters that I found a way to tweak just right a while ago). Any suggestions are welcome!

What version of Scrivener, please?

If you do a partial Compile, say of the chapters before and after the issue, does it still cut off?

Hello! 3.3.1 on a MBA with Ventura 13.3.1. All is up to date.

I did a partial compile, and it indeed worked (just for that chapter). However if I do the complete compile, it cuts off. Very odd.

If the text cut off implicates a particular document, I would use the Zap Gremlins command on the doc and see if that helped. (Not kidding. That is a for-real Scrivener function.)

BTW, to run the test @kewms suggested, you really need to select a portion that includes documents/material clearly before the cutoff and extends all the way to material/docs that would go beyond the cutoff. It is a bit unclear from what you say whether the test you ran did this. So, am just checking in.