When does Scriv display cards, when text?

I am working with the binder and two editor windows, with the lower window set to show what’s selected in the binder. I click on a document in the binder, and the lower window shows the item’s sub-documents as cards. I click on a card, and this causes the contents of the card to be shown on the upper window. So far so good.

But what I want is for the upper window to display the sub-documents of the card in the lower window, as cards. So I click on the corkboard icon in the main toolbar.

But when I go back into the lower window, and select another card, this setting changes and Scriv displays the text contents of the card again, and not its sub-documents.

How can I make this setting sticky, so that I can switch between cards in the lower window, and the upper window will always display cards too?

And for the times when I want a different set-up, a more general question: What are the rules that govern whether Scriv displays cards or text? I’ve been using the program for months now and still can’t work this out.

One for the wishlist: an option on the ‘View/Binder Affects/’ menu for ‘Both Editors’. This would allow me to click on items in the Binder and see its contents in one window, and its sub-documents in the other (given I can get my head around the problem above :confused: ).

And to save “Binder affects” settings, with the layout or configuration or wherever.

Can anyone help with this? Or point me to a post or somewhere in the documentation where it is explained?

Select Tool->Options. On the Navigation pane, there are 3 checkboxes at the top.
1: Treat all documents with children as folders
2: Include enclosing group in combined scrivenings
3: irrelevant

Check the 1st and see if that makes things behave as you want. If not, un-check the 2nd box.

Eventually, once the Windows version catches up with the Mac version, this will just be a guide-line, as Scrivener will remember how you last viewed a particular container’s contents (scrivenings mode, the container as a single document, or in cork board mode). Until that time, you either get the text of your container, or you get a corkboard of it’s children across the entire project.

Thanks for this.

I’ve experimented with this setting. I can’t see that it makes any difference.

This is very helpful. I’ll keep trying!

Can’t see any difference, either.

What robertdguthrie said about the Mac-version seems to work on Windows, too: the last view is remembered per container. What simeva is asking for, however, (if I understood you correctly) is assigning a fixed view (index cards) to an editor, not to the container where it was last used.

This would allow to always see index cards in this editor, no matter whether a container was last displayed in text view or card view.

Oddly, things are working as I described on my Windows version: the settings I went over work every time I click on a folder or document stack, but when I change the view after that, click away from that stack/folder and then come back, it goes back to the default.

Weird.

Yes, that is indeed what I would like, and usually the program behaves like this.

I think I’ve now cracked it.

My set-up is: split windows in the editor, four containers in the lower window - an empty file, a file with children, an empty folder and a folder with children. ‘Automatically open selection in other editor pane’ is set to ‘on’.

Each Editor window has a view associated with it: document/scrivenings, corkboard or outliner.

If document/scrivenings view is set on the upper editor, and you switch focus to the lower window:

  • all containers are shown in document/scrivenings view.

If corkboard (or outliner) view is selected in the upper editor, and you switch focus to the lower window:

  • empty files are always shown in document/scrivenings view
  • folders are always shown in corkboard (or outliner) view
  • IF the ‘1: Treat all documents with children as folders’ option is set THEN files with children are shown in corkboard (or outliner) view ELSE they are shown in document/scrivenings view

What goes wrong for me is this:

The upper window will only remember a change of view from document/scrivenings to corkboard or outliner if a folder is selected in the lower window.

If a file is selected in the lower window

  • and the upper window view is document/scrivenings
  • and the focus is changed to the upper window
  • and the view is changed to corkboard or outliner
  • and the focus is changed back to the lower window
  • and a folder is selected in the lower window
    then the view in the upper window has reverted to document/scrivenings.

Perhaps this is a bug.

Hmm, I cannot reproduce your findings, simeva,

where did you find this option:

Is this a corkboard/outliner setting? Or did you mean putting a checkmark next to
VIEW > Binder Affects > Other Editor
If so, does Scrivener remember this setting, or is it up to you to remember changing it again each time you start up Scrivener? On my machine it always reverts back to the default “Binder Affects > Current Editor”

Let us use this default setting (Current Editor) and stick with ONE Editor only, to keep things simple:
In the binder:

  1. You click on chapter_1 that contains child scenes. Set it to Doc/Scrivener View
  2. You select chapter_2 that also contains child scenes. Set it to Corkboard view
    What happens when you click the back-arrow of the Editor?
    Will it show chapter_1 in Doc-View (as it does here, just like robertdguthrie said it would)
    Or does it keep your Corkboard view?

This option is available on a button on the left side of the footer bar when the editor is in corkboard mode. It is a pair of vertical arrows on top of each other. Hover the mouse over it to see the tooltip ‘Automatically open selection in other editor pane’. The arrows are blue when the option is selected, black when not.

I did as you suggested. What actually happened when I hit the back-arrow of the Editor was that a random file I had been editing yesterday was displayed - a bug I and others have reported elsewhere. But after clearing the document history, Scriv behaves as you describe.

I rarely work in one Editor. I suspect that ‘Keeping things simple’ removes the condition that causes the bug I am describing here (if it is one), which arises because Scriv loses track of which mode it is in when the user switches between editor windows.

Thanks for pointing out the back-arrow-bug, simeva,

it doesn’t happen on my machine, though. But maybe it causes the seemingly random behavior. Sometimes it works the way robertdguthrie explained it. Other times it matches your description, but not consistently.

Could well be. I am giving up on figuring this out. Too many iffy parameters in the equation.

What additionally confuses me is Scrivener not keeping my setting in VIEW > Binder Affects > Other Editor. Sometimes I just fire it up and hack away, without remembering to first change that setting again. That may also cause to thwart my expectations of what viewing mode a document/editor will use.

Yes - it would be helpful if Scriv remembered this.
Also agree that life’s too short to spend any more time on this! :wink: