When I edit / add text the texts jumps up or down. How could one avoid it?

When I edit / add / delete text / phrases / words the text in the editor jumps up or down. How could one avoid it?

Are you using typewriter mode so the currently edited line is centered?

Do you have Typewriter mode on? It’s designed to keep the cursor at a certain point in the editing window, so if you’re moving around to edit different parts of the text, it will shift the page around to accommodate that.

I don’t have the Windows version so can’t tell you which menu the feature is on, I’m sorry, but there’ll be a shortcut for it as it’s designed to be toggled on and off quickly.

No, it is not activated:

That setting is the default for new projects, but AFAIR even in the V2 you can toggle it on and off for a session without changing that default (the idea is basically that you use it when you’re writing and turn it off when you’re editing). If you go into Keyboard options and search for Typewriter there should be a shortcut for it to use ad hoc when you need it.

Search for Typewriter scrolling in the Help menu if you don’t find the menu command.
It’s possible you unknowingly activated it with the shortcut.

Ah yes, that’s it.

I assume, it is shown somewhere but I cannot find any display showing whether that option is activated or not.

Yes, I would think so, too, but I guess, that is not possible, the two shortcuts didn’t work.

Very irritating: although the option is turned off in the options it is not.

Many thanks!

The feature works independently in normal editing mode and in Full Screen composition mode — you have to toggle it on or off in each mode.

It’s been years since I used the old version so can’t tell you where the menu option is (or if there actually is one), sorry.Perhaps the shortcut toggles the tick box you showed a screen shot of?

Yes, I had found them.

No, it does not, that is what I meant by irritating. Sorry, what old version?

Both the Mac and the Windows Beta versions have a menu entry for Typewriter Scrolling (View > Text Editing > Typewriter Scrolling) and there’s a tick against it when the feature is on, none when it’s off.

It’s been years since I used the Windows current release and in any case, the menu structure is different because there are so many new features, so I can’t remember if there’s an equivalent menu item.

Biff,

In v1.9 you can customize the Main Toolbar to add an icon for Typewriter scrolling. Tools > Customize Toolbars > select Main Toolbar > select Typewriter Scrolling.

The icon will show you whether Typewriter Scrolling is enabled for each editor. It’s a separate setting for the left editor and the right editor.

Unfortunately, in v1.9 there is no visible icon for Full Screen mode (but there is in the beta!).

In v1.9, from both the left and right editors, and also in Full Screen, you can toggle Typewriter scrolling by pressing Ctrl-G, Ctrl-T.

Best,
Jim

Cannot find it here.

Yes, of course, may be some day I will find it, thank you.

Hello Jim,

Great, an icon, it is shown now, thank you.

Yes, those shortcuts do not work here (are used by another program, I assume), I have set another one that works.

Many thanks

In v1.9, it’s under Format > Options > Typewriter Scrolling. Of course, now that you have the icon, you don’t need to know that anymore. :mrgreen:

Ah, format, I would not have thought that. Well, may be I should know that though.anyway, if the icon suddenly disappears (like the favorites icons).

Thank you!