When I import a doc I don't want it included in export..?

How can I turn this off? I’d like to add doc by importing and clicking “add new text document” without having them automatically included in exports (as I only export one a a time in most of my projects), but I can’t figure out where to change this setting it is possible?


If you are exporting one file at a time, can’t you just do it by choosing File -> Export -> Files, which will only export the file(s) currently selected in the Binder?

Or am I missing something in your meaning?

That’s not the problem, I just do not want Scrivener to assume that when I add a file, I will want to export it when I export anything. I want Scrivener to just add the file and leave it unchecked so when I do export my project, I can just export one file and not have to unclick everything I’ve been adding.

Background: I’m not writing a novel, I’m collecting jobs from clients that I translate for. Scrivener is a great tool for this. It’s super easy to keep track of all my work, and I use the research folder to contain client specific terms, etc., etc. Wonderful! But obviously I need to export each job as an individual item so rather than have to unclick each job every time I create or add one, I just want to go to export have all the files blank and then choose the one I currently need.

It just seems like it should be easy to turn that off, but I can’t find the switch.

ETA: I think exporting exports the files which are checked as include, not the ones highlighted in the binder. Maybe this is a new function? I’m using version 1.11.

This can’t be done, but it may be that you are approaching this in the wrong manner. To explain:

The “Include in Compile” checkbox affects File > Compile Draft. The whole purpose of Compile Draft is to export or print the entire contents of the “Draft” folder as though it were one file - that is, compiling it. Anything with “Include in Compile” checked gets included in the compilation. If you are adding a text document to the Draft folder, it is therefore a reasonable expectation that you will want it included in the compiling process in the majority of cases. In rare instances, however, it is possible that a user may want to drop a notes file into the Draft folder that doesn’t get included in the compilation process - and for that, they can uncheck the “Include in Compile” checkbox for that document. The checkbox has no effect anywhere outside of the Draft folder (and hence it is greyed out).

In your case, it sounds as though you aren’t even using the power of the Compile Draft feature, so may not need it. So, here are some better options, if I understand you correctly:

• Select the document you want exported in the binder, and instead of using File > Compile Draft, use File > Export > Files… This will export only the selected documents. “Include in Compile” has no effect on which documents get exported in this manner.
• If there is some reason that you do wish to use Compile Draft - perhaps for overriding the export format or whatever - then set up a different folder inside the Draft folder for each project. When using Compile Draft, you can choose the subfolder within the Draft folder that should be exported (you don’t have to export the whole draft), so you can just choose the folder for that particular project (which may only contain one file).

In a way, you are using Scrivener in a way for which it wasn’t intended, in that Scrivener is based around the idea that you are working on a large project in small parts that will need compiling into a longer text, when this isn’t what you are doing. But the above routes should do what you want.

Hope that helps.
All the best,

Ha! First, I admit I am using Scrivener in an unorthodox way. Hehe, it’s not my fault Scrivener is the best program for my purposes!

But I have been inadvertently Compiling Draft rather than File->Export->File. I was convinced I was using file-export-file, but had the keyboard command confused, mixing up the alt and shift keys…

I am quite the happy person now, thanks. :mrgreen:

Glad to help.
All the best,