Where do I find "Show binder titles in editor"

I have one project where my binder titles show up in the text area of the editor pane and another where they don’t.
I have looked everywhere for the setting and can seem to find it. Needless to say, the search verbs of the forum or of the manual’s PDF file weren’t much help.

Do you mean in “Scrivenings Mode” (when you can view several documents as one, and edit them in place)? If so, you need to choose Format > Options > Show Titles in Scrivenings.