White highlighting in composition mode

Hi all. I’m experiencing a distracting problem that I’ve mostly ignored, but it’s driving me mad. When I write in composition mode, my text is highlighted in white on an off-white background. I haven’t (intentionally) selected a highlighting feature. The white highlighting flickers when I type and it’s a concentration killer.

I’m on a Mac using Ventura 13.3, though this isn’t a new problem—it’s definitely persisted through muliple system updates.

Any idea what’s happening here and how to resolve it? I have a screenshot I can share…

The first thing you should do is see if your text is actually really highlighted.
Get out of composition mode and remove the highlight from a good portion of your text…

image

…back in composition mode, type and see if you still get the flickering for the text segment you just (hopefully) fixed.

If you don’t : good.

Go to options and remove the highlight from your default formatting.

Check your project settings to make sure the default formatting comes from the options.
If it is rather set per this project, fix the highlighting there too.

Manually remove the highlight from your text everywhere else (in the editor) or convert your documents to default formatting.

Since you say it has been going on for a long time, check your styles if any. You may unknowingly have built them with the highlight included. But if your styles don’t have a image in the list, nevermind, as they wouldn’t save highlighting as a style’s parameter.

P.S. These are Windows screenshots.

Thanks, Vincent! That actually did it. Out of composition mode, if I select the text and open the highlighting box, it doesn’t show that white (or any) highlighting is selecting, but when I set to none, all the white disappears.

1 Like

Fix your default formatting.
You must have inadvertently highlighted it at some point.
(There is no way to tell. – Just remove it.)