Why aren't titles showing in chapter sub-folders

Any idea what is wrong with my compile settings? I want the title to display for the chapter and for the folders within the chapter folders. Instead, the separator # marks the change of each scene instead of displaying the title.

As you can see in the screenshot, I have selected the title to show in all three tiers.

I guess my workaround is to convert each file to a chapter or folder.

Thanks for any help.
scriv titles.png

It would help if you showed a complete screenshot showing both the binder and the compile settings, so we can see what is highlighted by each level.

Are the files/folders in question set to Compile As-Is? That command overrides the entire Formatting pane.


No files are set to override as “compile is.” All folders and displayed sub folders are set to show the title and text, yet that is not how it is compiling. I’m going to convert everything to folders and see if that helps.

It’s hard to say without seeing the Binder, but the most common reason for this problem is a mismatch between the Formatting pane and the Binder. That is, the Binder hierarchy is not reflected in the options you’ve chosen in the Formatting pane.

To resolve the issue, I would need to see (1) the full Formatting pane. It appears – from the scrollbar at the right – that there are levels defined that don’t appear in the screenshot you posted. And (2) the fully expanded Binder structure. The Formatting pane by itself is meaningless without knowing how it interacts with your actual outline.

Converting everything to a Folder will probably solve the immediate issue, but of course makes it impossible to format different section types differently. Whether that’s a desirable tradeoff is up to you.


The screenshot in my original post I thought covered all possible folders, files and sub-files. But I see what you are talking about. When I click on the second and third tiers, it does not highlight in the binder.

My chapters were set as folders and each file inside the folder was created by clicking the “add text” button and typing scenes. Why wouldn’t these “add text” or “scene” files be covered in compile under one of the three tiers?

I am not a rookie, but I sure made a rookie blunder. I did not see the list of sub-folders until scrolling in the compile window.

That was my first mistake.

The second was that my files were at the lowest sub-level, which I didn’t see because I didn’t scroll to the bottom of the compile. When I clicked “add text,” the files were not at the level just below my folder. When I moved them all left, my settings worked.

My only excuse is that I only compile after the book is done – my second using Scrivener. It’s so outstanding for organizing and crafting 100,000 words into a book. It’s not as user-friendly when it comes to that techie stuff of formatting and compiling.

Thanks for such quick responses and for trying to help. But, as the comedian said, “You can’t fix stupid.” And that was me. :slight_smile:

The Format pane in Compile might seem complicated, but it has to be a bit complicated to make it possible to have a complicated structure with different hierarchial levels in the text. Using different levels in the Binder in a clever way it’s possible to format various sub-parts within chapters within book parts differently.

The bottom tier in the Formatting screenshot you sent included documents with no sub-documents, in Level 1 only. A document that is inside a folder is already at Level 2 at least, maybe further down depending on the level of granularity in your Binder.