Why did Scrivener wipe out my work with trial version?

I pre-purchased Scrivener for Windows on 11/4/2011. I was working through the midnight on November 7th using the trial version. I was periodically saving my file. During my work I navigated back through previous sections only to find that it the text was completely gone. I tried to restore a version I saved as with another name earlier in the day and discovered missing text. Where did it go and how do I get it back. I am not writing a novel, this was an important white paper for work. Urgent help needed. I figured I was just locked out of my file and that once I keyed in my license serial number I would then regain access to my text. This was not the case.

Where you using “Save As” to periodically save your work? I ask because if you do a “Save As”, you will create a copy of your project and then immediately be editing that version INSTEAD of the original. If you then close Scrivener and open the original project, your edits will be in the SAVE AS copy, and not the one you started with.

I’m having trouble too; I’m currently re-installing and hoping that takes care of it.

I love the implication that the novel I’m writing is not important, though! :laughing:

Going past midnight on the 7th shouldn’t have done anything to your work; the expiration date would just kick in when you next opened the program, informing you that you needed to update to the latest version. The projects themselves aren’t tied to a particular version and are saved on your hard drive at the location you specified when creating the projet, and these don’t get altered when installing, uninstalling, etc.

Try running a Windows search for some unique words or phrases from your missing text. Since Scrivener projects are just stored as regular folders and files on your drive, with your writing saved in the RTF format, the search should find your documents if they’re in the project. If you do get some results (numbered .rtf files), check the file path to see where they’re located and make sure that it’s the same project file you were working with. It’s possible they’re still in the project but just not properly being displayed, so give this a shot and let me know if you find anything.

To Icarus - didn’t mean to imply your novel was not important - merely meant to distinguish that I am on a very short deadline for work, not part of the NaNoWriMo currently going on.

To MimeticMouton, robertdguthrie - I was saving and additionally using [saved as] to create a copy on an external drive and would return to my original to continue to work. Sometime during the editing and switching back and forth between sections I noticed most of my text had disappeared. At first I didn’t panic because I new I had saved additional files. When I checked those files apparently I was saving the same blank text. Coincidentally, the only thing I could tie in was the change over from trial to licensed.

I have found and managed to recover some information in the numbered .rtf files from a day ago but all the iterations of saved and saved as show up empty. Thanks for your suggestions.

wjbond7 - I am sincerely sorry about the loss, although I’m glad you’ve managed to recover at least some of the text. If you have a moment, could you check the Windows error logs to see if there’s a report from around the time you noticed the text going missing?

To grab the error report generated by Windows*:

  1. Open the Control Panel and choose Administrative Tools (under System and Security if you’re viewing categories)
  2. Open Computer Management
  3. In the tree view, select System Tools\Event Viewer\Windows Logs\Application
  4. In the window on the right, you should see a list of reports Information, Error, and Warning. Group these by date and sort by level, and then look for any errors that occurred at the time of your crash–the source column should say something like “Application Error” or “Application Hang”. Selecting any one should show you the details in the lower part of the window; you can also double click to open it in a new window. Make sure that “Scrivener.exe” is referenced in the description of the error, and then use the Copy button to send the contents to your clipboard (if you get an option, choose “copy details as text” rather than “copy table”).
  5. Paste the error details in a post here, or alternatively send them to support AT literatureandlatte DOT com.

That might help us figure out what happened to prevent its occurring again.

  • These steps are for Windows 7; Vista and XP may be slightly different. In XP I believe the path in step 3 is just System Tools\Event Viewer\Application

I too have lost chapters of my saved Novel. I’m not very “geek” savy and some of what you are telling the previous client goes over my head.

Is there someone who can walk me through steps that might reclaim my lost chapters?

Really upset at the moment–nearly 15 hours of work gone.

Help!
Deskjet

Hi MimeticMouton. I just had this happen to me as well. Nothing logged to the Event Viewer. Looks like it’s blowing away the .scrivx file in the project folder when it tries to load it. That file shows as 0 bytes for the affected project. I tried copying the XML from another .scrivx file into the empty file and reloading it in Scrivener. Scrivener wipes it out and doesn’t load the project. I opened the Scrivener executable up in the debugger in Visual Studio. The only exception thrown is something related to an RPC server not being ready. (I’m not sure that’s the actual issue here.) Also related to the Event Viewer you might want to have your development team register a Scrivener event viewer source in Windows during installation. This will make it a lot easier to view the errors that Scrivener logs because you can filter by just the Scrivener events.

Also unrelated to this issue but related to the forums, you might want to add SSL encryption to the forum’s login page. It’s sending credentials in the clear. Also I wasn’t impressed when you sent me my username and password in a plain text e-mail when I registered for the forum. That’s something you guys should clear up right away.

I love Scrivener, and look forward to buying it when you guys get these first bugs worked out!

Thanks, Trevor Vass

UPDATE: Looks like the docs.checksum file gets blanked as well. Could this be the problem? Bad checksums from the beta to the new version?

UPDATE: I verified that the hash used in the checksums file does create the correct values (using SHA1). Recreating the blanked file doesn’t help though. That’s all the info I could drudge up about the problem tonight. I’m willing to collect more data for you guys if you have a potential solution. Thanks!

Deskjet - I’m truly sorry! Are you using 1.0? If so, Scrivener will have made a backup of your project automatically when you last closed it, so that’s something to check–you may be able to restore most or all of the work from a backup. In the “Backup” tab of Tools>Options… you’ll see a button to open the backups location; this will open that folder in Windows Explorer, and you’ll be able to check what backups you have there. Backups are stored with the project name an a date-stamp, so look for the last couple from the project that’s missing text and copy those out to your desktop or somewhere that you can unzip them and open them to check the contents.

Before you start opening the backups, it’ll be a good idea to rename the current one something like “ProjectNameLOSTTEXT.scriv” or the like so that you can keep from getting hte versions confused. If the project is already open in Scrivener, first choose File > Back Up > Exclude from Automatic Backups, then go ahead and closed (if it’s already closed, don’t worry about that step). Navigate in Windows Explorer to where you’ve saved the project–it will be in your Documents folder if you didn’t change the default location, so you’ll find a folder there called “ProjectName.scriv” and that’s what you’ll want to rename. Then right-click on the backup(s) you copied out of the backup folder and choose “Extract all” to unzip it to a new folder. Once that’s done, double-click the .scrivx file in the unzipped project to open it in Scrivener and you can take a look to see if the missing chapters are there.

If this one is still missing text, choose File > Back Up > Exclude from Automatic Backups and close it, then repeat the extraction process on the second most recent backup, etc.–since you’ll have gotten a backup every time you closed, you might have one or two that were created after the text had gone missing and you were poking around in the project. Once you find one that has the files that got deleted, you can either choose to just use this as the new main project, replacing your “LOSTTEXT” version, or you can open this side by side with the current missing-text version and drag missing files from one project binder to the other. (Alternatively you could cut and paste the text from each missing document to where it belongs, whichever you like.)

If you’re just going to restore the backup, you can close the project and then move or delete the “LOSTTEXT” Scrivener folder and move the good backup version of the .scriv folder to your Documents folder (or wherever you’re keeping your .scriv projects). Then just double-click the .scrivx file or use Open from the Scrivener to select that project and you can continue working.

Trevor - Likewise, I’m incredibly sorry you’ve lost some text! Thank you for taking a look in the Event Viewer. You mention losing the .scrivx file–are the RTF files in the Docs folder of your project also missing or is just the .scrivx corrupt? If the latter, the project can probably be restored pretty quickly by replacing the .scrivx with the one saved in binder.autosave or binder.backup, within your project. (They’re just zip files, so rename the extension to .zip and you’ll be able to easily extract the .scrvix backed up inside.)

I’ll check on the forum notes and see what we can do.

Tried restoring from the binder.backup and binder.autosave as directed. No luck. I think it’s dying while parsing the .scrivx file. The RTF files are still in the folder, so I’m pretty sure I haven’t lost any text… just can’t load what’s there because of the bad project file. I have backups from another machine as well, which I’ve tried with no luck. I thought about possibly recreating the project by copying and pasting the RTF and TXT files into a new project. That’s cludgey but may work.

Thanks! Trevor Vass

This thread is the closest analog I can find to the problem I’m having, identical to the issues and circumstances described here, save one key point: the RTF files that should be in the \Files\Docs subdirectory are nowhere to be found.
I have a project that worked fine with the trial and is now just metadata. Not one word of the 30k or so is there.
I’m not sure when this occurred. I just revisited this project yesterday after a long hiatus. I only appear to have two Scrivener-created backups, both useless (as they recreate the problem).
Before I dive into system imaging archives, has anyone else hit this issue?
Edit:
Nothing in Event Viewer, but I only keep a month’s worth of logs (as prior logs are rolled into backups).
I’m just perplexed as hell.

bcarruth - Which version of Scrivener are you using, a NaNoWriMo trial (045 or 046) or the 1.0 trial? If the latter, you’ll have the five most recent automatic backups stored in your AppData directory, accessible via the “Backup” tab in Tools > Options… If you’ve opened and closed the project several times since you discovered the problem, you’ll probably need to go to the earlier backups, but it’s worth copying those out and unzipping them to see if you have one that contains all your files as it should. If you open this project again that’s missing the RTFs, go to FIle > Backup > Exclude from Automatic Backups to prevent it from adding any additional corrupt backups to the collection and bumping out older, potentially better, versions.

It was the 1.0 trial, though I’ve since purchased the full version. I found the backups in the location you mentioned (prior to reading this, via file search on the drive). There were only two backups, same problem as the one described above. Again, this project had been lying fallow for quite some time. I had hoped there was an additional location where files might have been stashed or mirrored (ala Windows Recent or AppData folders). Seems that’s not the case.
I’ll look through Windows backups and see if I don’t have a copy there :-/

AppData contains configuration files and such; the only place there you’d find the project files would be in the automatic backups folder. Since it was a while ago in the beta stage that you were working on it, though, prior to Scrivener making auto-backups, you probably made your own manual backups, which you could’ve titled something else–if you haven’t, look through your .zip files and also take a look for the .scriv extension in addition to just searching for the project name, in case you backed up not as zip or used a “Save As” or other copy method at any point to backup the project. If you run automatic system backups as well then there’s a good shot you’ll find something there. I’m assuming from your comment of it having lain fallow a while and there being only two automatic backups, both missing the RTFs that the text was missing from the point of opening in 1.0 (trial mode or registered is unimportant)?

Another thing to try, take a peek in your project folder and backups for the “search.indexes” file and see if it has any of your text saved in there as plain-text.