Why do I have the # symbol throughout my final compile?

Hello,

Why do I have the # symbol throughout my final compile?
How can I fix or take advantage of this?

Thanks,
TG

Here is an existing discussion on this, with instructions on how to change the settings (though you may want to approach things by avoiding empty lines between paragraphs unless you want a formal section break).