Why does Scrivener not export my text?

Hi,

I’m new to Scrivener and am exporting a mss for the first time. I’ve got a bunch of folders each with its own text document inside, and want to make one long document, but with a title for each folder/section. (It’s a collection of short essays.) Each folder has a title and I want that title to show up inside the document.

When I try to compile and export, however, I get this: CHAPTER ONE, then the title of the folder, and NO TEXT.

I’ve tried various different things, unchecking and checking various boxes, but can’t get the text to export.

I’m going crazy with frustration here, and thinking that Word was just so, SO much easier (i.e. regretting my Scrivener purchase :cry: )

Can anyone help? Thanks!

Can you tell (or show with a screen capture) what your Formatting compile settings are? Do the appropriate rows show check-marks on the Text column? Are the “Include in Compile” checkmarks in the Contents pane showing as checked for your text documents?

Edit: By the way, if your window is wide enough and the binder is visible, make sure that some of your chapters & the text files in those folders are visible. When you select a row in the Formatting pane of compile, it will highlight the folders or documents which that row will affect. Note that having a setting (like the include-in-compile checkbox) set to exclude a document will prevent it from being highlighted.

Hello and thank you very much for this reply! Somehow I didn’t get notified that it was here … so much to learn!!

Anyway, on trying this again I highlighted the folders I wanted to compile, and that way managed to get the text included. However, none of the titles show up. I wonder if that’s because, instead of having each essay as a text document inside a folder, I set them up as separate folders. (Did I mention this is my first time using Scrivener?)

Is there a way to treat the folders as text documents so that the titles of them show up? Or should I go back and re-do everything, i.e. copying each folder into a text document (would rather not, truth be told - there are 50 of them).

Also, I discover in my compile process that italicized words show up as underlined. Is there a way to rectify that?

Finally, I have no folder in my binder for front matter, as I’ve seen on the tutorial videos I’ve watched. So I have no idea where to add my metadata.

Many many questions, I know, but I would be grateful for any help. Thanks so much!

That might be the problem right there, if you are using the selection to compile. I wouldn’t recommend doing that unless you are specifically trying to only compile a piece of your manuscript (like say, only the first and fifth essays). In general you can just leave the selector at the top of the Contents compile option pane to “Draft” (or whatever the master draft folder is called in your project). The way selection works in Scrivener is exclusive. If you select a folder, that does not automatically imply that its indented items will also be included. You can set it to work that way, but like I say, if you just want the whole Draft compiled, you might as well not worry about selecting things specifically.

Or, if you mean something else by selection, let me know. There are several ways to filter out portions of the draft.

All right, to the problem of titles and text: all of this is controlled in the Formatting compile option pane, as Robert mentioned. Go ahead and click there in the compile sidebar and examine the grid in the top half. The checkboxes determine what will be exported for each type of icon. I can’t say precisely what you’ll see here, but a common scenario is for folders to export their titles, but nothing else, whereas text files may export both at level one (which means directly beneath the master Draft folder, not indented beneath folders), but only text at level two or greater. This way you can have single-file sections like a Preface that print both the title and the text from a file, but the files inside folders go on acting more like sub-components of the chapter—this lets you write and organise your work into smaller chunks than are worth distinction to the reader.

If the checkboxes in the upper half of the Formatting pane look right, and everything is listed in the Contents pane that you want listed, then you should be okay for titles and text. You may want to tweak the output for titles though, as it sounds like you’ve started with a template that assumes you’ll be writing a book with chapters, rather than a collection of essays. If you click on the Folder row in the top half, you should see a preview of what the title will appear like in the bottom half. To change the content of the title, click the Section Layout… button. The rest should be self-explanatory—basically the prefix gets inserted before the name of the folder, the suffix after, or if the title checkbox is disabled, these fields can print data anyway, making it possible to print generic titles like “Chapter One” without any names.

In short, there is no need to go back and redo your entire binder layout from what I’m hearing. The compiler is quite flexible and can work with just about any outline scheme. It just sounds like the compiler needs to be adjusted a bit, as described.

(And for future reference, if you’re just going to have major sections composed of a single file, it might be easier to just have a flat list of files in the Draft, rather than sorting one single file into one single folder like that. It will make working with the outline much easier for you, as you can get a quick overview of all your sections from the Corkboard/Outliner, and just overall have less clutter in your work space. But like I say, there is no need to waste a bunch of time doing that right now, the compiler can most likely be tuned to work with what you’ve already got.)

Check the Transformations compile option pane. There is a checkbox in there for conversion of italics to underscore.

You don’t need a front matter folder unless you intend to be switching front matter frequently. For example if someone is self-publishing to PDF, Amazon and Barnes & Noble, they might need entirely different title pages, copyright pages and so on. Front matter makes it easy to switch these on the fly whenever you compile. If you just have one title page, introduction, dedication page and all that, you can just create these as individual files in your Draft in the order they should appear.

Note that to create a page break, you’ll want to open the Inspector and check off the “Page Break Before” box. This will cause the current section to emit a page break—useful for most front matter sections. (By default, folders automatically get a page break, as set in the Separators pane). One other checkbox that will be of interest to you is the “Compile As-Is” flag. You’ll need that for any section that shouldn’t have a title but otherwise would. For example you would not want your title page file to be itself titled—you just want it to print precisely as-is.

That’s probably a lot to digest, so let us know if anything requires more explanation or screenshots.

Hi again,

I’ve been trying to work my way through this with a modicum of success. However, I seem to be stuck on the fact that there is no “drafts” folder - I only have a folder called “Manuscript” in which all my stuff is located. When I try to compile, however, I get the message that there is nothing to compile, and that I should click on “Contents” in the compile window and select some documents. However, in the contents section all I get is something called “current selection” but nothing in the actual box underneath.

What am I doing wrong?

Update: I have tried highlighting the sections I want and that way get them all in the pane I alluded to above, but I still don’t get the titles. The only place I get a title is in the “Foreword” section, because the introduction is written in the document that was provided for me. I also get a generic “Chapter One” above it, which I absolutely don’t want. Argh.

Also, on top of each page there is a header with my name and the name of the book on it. Is there a way to be rid of that?

This all seems so complicated! :frowning:

ps - I have included a screen shot of the formatting pane as it looks before I try to compile (and don’t get the titles)
Screen Shot 2014-01-08 at 16.24.28.png

In the Contents section, click on the “Current Selection” drop-down list and select “Manuscript” from the list.

The reason you may see people using the term “Draft” is that the folder can be renamed, and is in many of the templates. In your case, the template you used to create your project has it named Manuscript. You can rename it to “Draft” if that’s less confusing, but it makes little difference.

A screen shot of your Contents pane would be helpful for specific advice regarding titles, chapter numbering and the like. Note that if you have the binder (and your manuscript within) visible when you open the compile window, the line you select in the Formatting section will highlight the affected documents & folders in the binder.

Hi Robert and thanks for your answers - we seem to be cross-posting here … :slight_smile:

As I mentioned above (in an edit) when I highlight “manuscript” and try to compile I get a message that there is nothing to compile. Indeed, there is nothing that appears in the contents pane, unless I highlight all the different sections.

Oops, apologies, I see what you mean now.

However, even with selecting “Manuscript” I don’t get the titles.

This screen shot shows the break between two folders. As you can see, no title. And my “formatting” pane is the same as above.

The other screen shot shows the binder folder, and then the break between two folders.


In the Contents pane, do you have the “as-is” checkboxes checked, or un-checked for your folders? If checked, that will suppress any settings made in the Formatting pane, including the insertion of Titles and “CHAPTER ONE” settings. To mass check or un-check all of those boxes, hold down the OPT key and click on one of the As-Is checkboxes. You may WANT the title page and such to be compiled as-is, but putting check-marks in that handful of documents should be much easier than un-checking all of your chapters.

Aha - that DID actually work, i.e. I had the “as-is” boxes checked. I have now un-checked them.

BUT now what I get is this generic CHAPTER ONE above my actual title, that I can’t seem to get rid of. When I un-click “title” in the Formatting pane, it takes away the title I want there, but leaves the CHAPTER ONE that I don’t want.

Is there any way around that?

Also, to leave a space or two between my title and the text below it?

Thank you!

Getting rid of the generic part of the title is done by clicking the Section Layout… button that is in between the formatting tool and the checkbox list. This is a per-row setting, so you need to select the item in the list that is generating the “Chapter One” before clicking on the button. Once you click that, you should see the generic text and number counter code. Just delete all of that to stick with your folder titles.

Put your cursor on the title line in the formatting editor, then use the Format/Text/Line and Paragraph Spacing… menu command, you can set up how much space should fall after the title, using the “Paragraph Spacing - After” line. This is in points, so if your font is 18pt, that is how much you would type in to add an empty line.

You could also add a couple of carriage returns to the suffix in the aforementioned Section Layout tool, but using formatting is going to produce a cleaner, flexible and more professional output.

Thank you Amber, that’s brilliant. I’ve now managed to get rid of the CHAPTER headings.

However I don’t quite see where I’m supposed to format the line spacing. I don’t actually see anything that says Format/Text … etc. Am I still looking at the Formatting pane?

EDIT: Found it! You’re referring to the menu bar up top I now see.

Sorry, that is a menu command. Just use the main menu, it is available for formatting in this window.

Looks like we’re cross-posting a bit. :slight_smile:

One more thing: is there a way I can get rid of having my last name and the name of the book at the top of every page when I format for print?

Take a look at the “Page Settings” section in the compile window. There should be some black text in one of the Header boxes. Note that there will be some grey text & codes that are prompts to guide you as to what you can put there; that stuff doesn’t actually go into the header or footer. You have to type something into those spots to have it appear in the header or footer.

Brilliant. Thanks.

There are a few other sticky issues (the title spacing not working, foreword different from rest of text etc.) but I think I’ve spent enough time on this. Time to export to Word and tweak there.

Thanks so much for your help Robert and Amber.