Why Does Scrivener Remove Photos from Word Files?

Hi,

I sometimes save online articles and put them in Scrivener’s Research folder.

I will often save these files to .PDF, but if there is the possibility I might want to edit them at a later date, I will save them to Word.

I notice that when I drag the Word files into the Research folder (and it is converted, I think, to RTF?), the files are stripped of any photos in the articles.

I find that strange, particularly considering that if I save the photo separately, I can then drop it into the converted Word file.

Some questions

  1. Why does Scrivener strip photo out of the file, when I initially drag it in to the Research folder?

  2. And why - if the photo is initially stripped out of the file when I put it in the Research folder - can I successfully add it back in to the file?

  3. Is there any way of circumventing the photos being stripped out (sometimes the articles I save contain quite a few photos, and it is tedious and takes a lot of time to manually save each one, and then add them to the article later on)?

Thanks for any replies.

The images are unfortunately being stripped as an effect of the conversion tool Scrivener uses to import the DOCX file. If you have Microsoft Word installed, as I gather you do, you can change Scrivener’s settings to use Word’s DOCX converter, which will preserve the embedded images. In Options, choose Sharing, then select the Conversions tab and click Import Converters. Select DOCX in the lefthand dropdown and switch the righthand from Aspose to Microsoft Office.

An alternative is to save the original files directly in the RTF format, which will likewise preserve the images on import.

3 Likes

Hi Vincent,
Many thanks for your replies.

I will try some of these ideas, but I do not want to make more work for myself than I have to, so some of the multi-step suggestions you are making are probably a little more work than my current, annoying workaround of saving and dropping the photos back into the file after it has been imported into Scrivener.

Thanks again for your help.

Thanks very much, MM.

A couple of questions occur to me.

  1. If I change the Scrivener’s settings to use Word’s DOCX converter, are you saying that will make DOCX / Microsoft Office the default (it would be such a hassle to have to do this every time I want to import a Word file that has photos in it)?

  2. If this does change the default setting, would it be for just the Project in which I change that setting (and perhaps for subsequent Scrivener projects I create), or will it change that for every Scrivener project I open, even if I created some of those several years ago?

Depending on your answers to those questions, I might just end up saving the original files to RTF at the time I am first saving them.

Thanks again.

It would be changing the default, which would apply to importing in all projects. (In general, anything in File > Options applies to the application as a whole, and project-specific options are under Project > zProject Settings.) So you would change the DOCX import converter to use Microsoft Office and apply the change, and then Scrivener would continue to use that until you chose to change it.

1 Like

As it is often the case, @MimeticMouton’s way is by far better than what I suggested. (I am tempted to delete my post altogether. [And so I did.])
Make sure you understand MM’s instructions. I believe it should not only work, but seamlessly. (You’d just go about things as you had planned to/were already doing, except that it would now preserve your images upon import. Nothing more than this one small change in the options, once, for you to do.)

Thanks very much, Jennifer.

Brilliant - I prefer the change to be an application-wide change, rather than just for that specific project (although I am really glad that we have the option to choose either).

Off to change that setting right now.

Thanks again.

Thanks very much Vincent.

Nothing wrong with your suggestions, and I am grateful to you for them.

Well, what I came up with [insert unflattering word here]ed big time in comparison to MM’s. lol

:melting_face:

You are being too harsh on yourself.

I really value learning multiple ways of going about things, though, as well as appreciating people trying to help.

I thought it was also interesting that MM said, as I had speculated, that RTF would work (but of course, one would have to go the extra ‘manual’ step each time of Save As RTF, so I have just changed the default setting as MM suggested).

2 Likes

UPDATE
Mimetic Mouton and Vincent_Vincent, I thought I would let you know that I am having some really strange problems trying to set the default to DOCX and Microsoft Office, so I am posting a detailed description of this using the ‘bug’ tag.