Why does the Find Window not keep selected attributes persistent?

Here’s a hypothetical scenario:

Let’s say I write a story and refer to the world wars as ‘WW I’ and ‘WW II’. In revision, I decide that’s an incorrect way to refer to them, and that I want to refer to them as ‘World War One’ and ‘World War II’.

So I invoke the Find Window and enter ‘WW’ into the Find field, and select ‘Ignore Case’.

Since I am trying to change two things that can be found with ‘WW’ but are not the same, placing what I want them to be changed to in the Replace field is not an option.

I find the first instance I want to change, and click into the Editor to change it. Then I re-invoke the Find Window to get it to be back on top of the Editor, and ‘Ignore Case’ is no longer selected. Why not? WTF?

This is absolutely not what I had in mind.

Why is there not a way to make ‘Ignore Case’ persistent? (hint, hint). Why would this not be automatically persistent until at least the point where I physically close the Find Window?

And why is there not an option to float the Find Window on top? When I have the Find Window on top of the Editor and select ‘Float Window’, it floats the Editor, over the top of the Find Window. That is also absolutely not what I had in mind.

It would make sense to me to float the Find Window automatically, were it not so ginormous.

A couple of points:

  1. Find Options persist for me in Mac V3.23 – in fact, I can’t find a way to make them not persist, and I’m not aware of any setting to do this. I’m not sure why you’re seeing different behaviour – as far as I remember, it’s been this way for years. (I’ve tried this with reinvoking cmd-f by the way, not just with the step below.)

  2. As a matter of simplifying your workflow, don’t ‘re-invoke the Find command’. Instead use the shortcut cmd-g which will take you directly to the next match (this is a Mac wide shortcut, BTW), or if you need it, cmd-shift-g to go to previous match. This doesn’t bring up the Find dialogue, because it’s not necessary until you want to change the terms of the search (when you use cmd-f again). What happens to the options when you use cmd-g instead of cmd-f - do the options still fail to persist?

I understand why you’d want the window to float if you’ve got a problem with the options persisting, but the solution is to find out why that’s happening, not making the normal workflow more annoying… an obtrusive find dialogue would be very distracting on a small screen in normal use.

Does the problem with non-persisting options happen in all projects, or just this one?

Also and quite incidentally to your point, since the example is hypothetical: it certainly seems you should be searching for ‘WW I’ not ‘WW’. That way, since the needed edit would just be a type or paste job, you can use the Replace field on the Find to do the job, albeit not globally.

(Or if you were me, you would first do a global replace on ‘WW II’ to something safe, then globally replace the ‘WW I’s, then do a global replace from the safety string/character to get all the ‘WW II’s back.)

1 Like

It persists for me (Windows + latest Scrivener version).

Something that could cause a seeming lack of persistence (depending on your perspective) is whether you are running project searches at the same time and taking any action that would refresh the search. Such will keep the Find panel settings synced to the project search parameters (more or less, there isn’t perfect parity between the two of course, but case sensitivity is one that does). This is so that the Find panel can be used to easily find individual instances of text you are searching for, even without loading the Find panel (i.e. using ⌘G immediately).

So avoiding actions that would refresh the list (like jumping between Binder and Search Results tabs) should help, if that is what is going on. Consider you can select all of the search results and dump everything into a temporary standard collection (with Documents ▸ Collections ▸ New Collection...) if you do want to work off of a list for a bit.

1 Like