Why is Compile skipping a file?

One of my included files is being skipped. The only change I’ve made to the compile specs is to use a Page Break between adjacent files instead of a black line. I’m wondering if that’s what did it, because the file that gets skipped is immediately following the only file I’ve got that’s less than one page long.

All help appreciated!

Is the skipped file at the same level as the other files?

Is it a text file, or a folder that contains text?

When checking the formatting levels used during compile, do you see the skipped file being highlighted to indicate that it is definitely being included?

[attachment=0]Compile Formatting.png[/attachment]

No. Here’s what the hierarchy looks like:

This:
Screen Shot 2016-11-19 at 10.18.28 AM.jpg
lights up the folders (Parts):
Screen Shot 2016-11-19 at 10.15.37 AM.jpg
The next two selections light up nothing. The Level 2+ selection lights up all the files in the folders EXCEPT the missing file.

I confess that I don’t yet understand the Formatting panel in the compile process, such as how the files are ordered by level, who ordered them that way, and how to change the level of a file…

Many thanks for the help!

Is the missing file shown in your images? Or is it somewhere inside one of the folders?

When you compile, do you see the missing file’s title, but not its body text?

Does the missing file have another text file as a child beneath it?

Does the missing file have an icon that looks like “TaDa” in the image below, or like the icon for “Different Level”?

[attachment=2]Icon.png[/attachment]

If the missing file does have an icon that looks like “TaDa”, does the text compile if you tick the Level 1+ text box (for files, not folders) as indicated in the image below?

[attachment=1]Level 1.jpg[/attachment]

If you expand the formatting box by grabbing the control and dragging downwards, do you see additional levels? Level 3 etc? If you do see additional levels and select them, does the missing file get highlighted?

[attachment=0]Expand.jpg[/attachment]

And is the missing file selected / ticked in the contents of compile?

[attachment=0]Contents.png[/attachment]

From the top:

  1. When I compile, I see nothing at all at that location. No title, no text.

  2. No, there’s no child file beneath it.

  3. The icon looks exactly like all the other text file icons: Screen Shot 2016-11-20 at 11.27.33 AM.jpg

  4. Interestingly, this is what the same section looks like in the Contents panel of Compile: Screen Shot 2016-11-20 at 11.36.02 AM.jpgThe file “Meets Raney” doesn’t appear in Contents, even though it is definitely ticked to be included in the Outliner.

  5. There are no additional levels available by dragging the control.

In the General pane of the Inspector, please check to see whether either the Include in Compile or the Compile As-Is box is checked/unchecked for the problem file.

Also, in the Compile -> Contents pane, are you using any of the Filter options?

Katherine

No 4 is interesting.

Are you compiling from a collection (that omits “Meets Raney”) or from the draft?

[attachment=0]Compile From Draft.png[/attachment]

OK, turning off the Filter tick mark fixed it!

Many thanks! I clearly need to study the options available. Otherwise, I credit Scrivener for letting me resurrect this long-dormant book!

Looks like this:


As mentioned in my reply above, turning off the Filter option appears to have fixed the problem.

Many thanks!

Glad it is fixed.

Good luck with the book.