Wicked neat Edit Scrivenings trick

While I still love Full Screen for drafting, I have been at a stage when I’m doing more with Edit Scrivenings, which is a definite Killer Feature of the Scrivener program.

I’ve been grouping my random-yet-related stuff into a folder, turning on Edit Scrivenings, and dragging stuff around, by paragraph into and out of different text files, and also by text file within the binder, until it flows properly. (The tint in my Edit Scrivenings is nice and obvious when I just turn off the Binder & Information windows, but is missing in Full Screen, which I figure is by design… and is why I haven’t been using Full Screen for it.)

When I am at the end of a section, and ready to add a new one, I can just click on the Add button I placed on my custom toolbar, and it adds a new, blank text file into the proper, next place in my Edit Scrivenings! I continue on, but it’s now a separate file that can easily be moved around if I decide it belongs better elsewhere.

The seeing-the-different-topics-as-different files aspect of this method has done wonders for freeing up my mind as I wrestle the last big section of my current book into submission to my will.

Or, to be Tao about it, letting it find its proper place without my all-thumbs interference :slight_smile:

This seems a good place to ask something I’ve been wondering about: What is the difference between the green, round Add button and the square white Text button in Custom Toolbar? The way I work, I can’t see any difference, but I figure there must be one.

Thank you, Keith! May your words forever flow as freely as wedding wine.

The square white button inserts only documents. With the green one, if you click and hold, a menu opens and you can choose among inserting a new folder or a new document. (There is also a button that inserts only folders.)

I’m not sure which version it originated in, since I’ve seen it since I started using scrivener in 1.03, but in fullscreen there is a definite subtle background color difference between files. Perhaps your color settings have been changed such that you don’t see the difference? You can even hit command-n for a new file in fullscreen mode to reproduce what you described.

Anyway, thanks for this tip! I try to live in fullscreen mode as much as possible. I hope I’m compatible with the workflow you described.

(Although, there appears to be an issue in the latest 1.1beta 1.07b which makes a status message get in the way when you command-n for a new file in fullscreen.)


I have played with the settings, but still do not see it in Full Screen.

I will download the Beta and see what that looks like… I don’t want to report it when it might have been already fixed.

I too do not see alternate Scrivenings colors in full screen (too bad, I would use it more often if I did). I have adjusted the color setting in preferences, but still nothing.

Could this be anomalous for some system set ups, like the continuing problem where when printing directly from the edit window some people seem to get pages numbers, and for others it is cut short?

I am runing a PowerBook G4 with OS 10.4.9.

Thanks for any suggestions.

Are you definitely using the latest beta? This was a known bug in previous betas, but seems to have been fixed in 1.07.

Good to know! Because it is does seem to be fixed in the latet beta, which I checked out.

Oddly enough, I am also running a PowerBook G4 with OX 10.4.10, and… loving it.