wide margins in editor

Texts which took up most of the editing screen in Scrivener 2 now have roughly 2" left and right margins in Scrivener 3, reducing substantially the text visible on the screen of my 13" MacBook Pro (late 2011). I have checked the format settings but cannot find the reason for this - the left & right indents under format/ paragraph are set to zero…

Welcome any advice

Having posted this and returned to the project on which I normally work I found that the margins had reverted to normal. But on a project I had not accessed for a while the margins were very wide. Maybe this is a temporary problem after conversion to Scrivener 3, but it is still very odd.

Scrivener -> Preferences -> Appearance -> Main Editor.

Either increase the default width or turn off “Use fixed width editor.”

Katherine

Hi Katherine

Thanks - problem now solved

Thank you so much for this fix. It was driving me crazy.

Thanks, this change from Scrivener 2 was quite annoying. On a 27" screen, you are per default suddenly only using ~40% of the window for actual writing! I would actually consider it a minor bug, since I really can’t see anyone actually using the default setting on a larger resolution screen.

It’s a YMMV thing – seeing a 27" wide wall of text is off-putting to me, so I always used to turn the Fixed-width toggle on in V2. For me the new default is exactly how it should be and I can’t imagine anyone wanting to use it the other way… :smiley:

There’s some (disputed, naturally) research which suggests there’s a optimal line width for writing / editing / reading of somewhere between 60 and 80-odd characters usually – or around 2 ½ alphabets wide) — I have mine set to about 66 chars which is great for Courier Prime 12pt at 175% zoom. Works well for both single and split editors, for me.

In the end, it’s personal preference and both are available.

Oh I am not disputing the personal aspects, I am only arguing that the default setting is too agressive for larger resolutions!
After scaling the font size to 18, which actually makes text readeable, you have something that looks like this:

Rather than changing the font-size (which keeps the width of the editor the same), increase the text-zoom (cmd-shift->). This will widen the editor width as well. You can set the default (I use 175%) in Preferences > Editing > Options.

This is the default (620 pixels) using Palatino 12pt at 175% – you can see the difference with your screenshot.

Of course, I’m not saying you shouldn’t want it to be different or that you’re wrong – just thought I’d mention that Zoom is the preferred solution here, rather than font size.

I use a 27" monitor for my own writing and the new fixed width default was in part in response to that - having wide walls of text drives me nuts. I chose the default width for the fixed width editor in 3.0 to work well on 27" monitor, providing an easily-readable column down the middle. If you don’t like it, you can of course change it.

I am curious why Zoom would be preferred. After all, the whole point of Scrivener and compilation is that you can set your text however you want without affecting the end, compiled product.

Because changing font size doesn’t change the size of the editor window and changing zoom does — I assume that’s to give you the flexibility to choose either. In this context, Zoom works better — and of course doesn’t affect Page View or Scriptwriting view where changing font-size is a problem, so it’s less hassle to change between views.

That would be my guess — no knowledge of the real thinking behind it of course.

Indeed, the width of the editor increases with zoom so that you still get the same number of words across.

For those of us who work at multiple screens (external 20" monitor vs. 13" laptop screen vs. 4" phone in my case), zooming works much better than fiddling with font sizes.

Because you should be able to generate a usable review draft without dealing with the Compile function, and having the mechanism for doing that (Print Current Document) spit out 18 point type is annoying.

And also because you shouldn’t have to use the capabilities of the Compile function if you don’t otherwise need them.

Katherine

While zooming is certainly the easiest way to adjust the overall scale of text along with the text column, the more fine-tuned approach—and the one we used to design the default relationship between editor width and font size isn’t too difficult to do however, and can be done visually and intuitively:

  1. Determine your preferred font size.
  2. Go into the Appearance: Main Editor preference pane and turn off Use fixed width editor.
  3. Resize the editor width until you find a line-width that is comfortable to your eyes.
  4. Click the Use Current button and flip the fixed width editor button back on and drag the editor out to preferred width.

Or optionally do the math and figure out what the best width is for the font size you’re using—if you’re like me you know roughly how many characters you prefer (I prefer around 80 characters, given years of working in terminal screens and such).

I would say there are advantages to doing that instead of zooming. For one if you use graphics at all, zooming will change the size of them as well. It’s also less complicated—in that every little measurement in the editor isn’t running through a transformation. So in theory there is less that can go wrong or slow things down. But if you never run into any quirks or typing lag then it’s not something to worry about.