Windows 1.2.1 Update Released 18th June 2012

Hi Windows Users,

We have just launched the update for Windows 1.2.1 and I wanted to let you know. If you are running Scrivener 1.0.3, you can update to the latest version by choosing ‘Check for Updates…’ from the Help menu, then simply follow the upgrade prompts.

Thank you for you patience. The official post is here to see the fixes and additions to Scrivener.
[url]https://forum.literatureandlatte.com/t/1-2-1-0-released-beta-ended/18395/1]
Regards

Lee

It doesn’t work! See my bug report.

You can update installing the current trial version … but, Al, you’re right:

Version 1.2.1.0 still doesn’t look for updates, but displays

No active network connection found
You need internet connection to check for updates

This is not a showstopper, but one of those little annoyances … if it was my prog, I’d fix it ASAP.

Thanks, Lee, for this quite impressive list of new features and corrections … perhaps in 2 years, when my yet-to-come new MB Air is worn out, I don’t need another one :slight_smile:.

I cant open my Scrivener after installing the update. I get a pop up box saying “The application has failed to start because its side-by-side configuration is incorrect. Please see the application event log or use the command-line sxstrace.exe tool for more detail”

I am also having this “side by side configuration” message - total show-stopper. I have uninstalled and reinstalled the version from the website, yet still getting the same error message, so figured the update must have changed settings in the registry. Have attempted to roll back my system with a restore from prior to the update, but the restore won’t complete successfully (never had this problem before). Also, the shadow copy of Scrivener generates the same error message. Now I’m stuck and watching my approaching deadlines with trepidation…

“Scrivener won’t start since the update” thread has the solution. Whew!

Same Problem here on W7 64bit.
Attempted all methods offered for instal.
In addition:-
Attempted installing in both Programs and Programs (X86) Folders Note: not at the same time :slight_smile:
Running registry cleaner between last attempts.
Trying to “Deactivate” bought up an error message, Copy of message attached.
Because I had an unresolved problem with installing 1.0.3 on an X.P. PC this w7 machine has had no Beta’s installed.
I have been able to re instal 1.0.3 without issues so will keep it installed until I see an answer :confused:

On Vista PC the upgrade installed over 1.0.3 without issues.
Snip.PNG

Installed from 1.03 without any problems. Dead easy. Maybe because I have Visual Studio 2010 installed?

Dunno, tried some things, very fast, very nice.

A big thanks for all your hard work Lee!

PS: What I especially noted was how fast Scrivener now display the draft folder with all masses of text inside. It was considerably slower in the beta.

What I am missing is a quick way to find the correct document/folder in the binder when I click somewhere in the editor. Would be nice to have an option to highlight the part in the binder with a shortcut or with a right-mouse-button option.

I’ve tried twice up upgrade and I’m getting the following C++ error message:

This application has requested the Runtime to terminate it in an unusual way.

This message occurs when the status bar reaches 100% and, I presume, the updater is about to close the program so it can update the application.

I’m using Windows 7.

I’d love to have this update. Any thoughts on how to get it done while the program is not actually running?

Could it be a windows 7 rights problem? I know when I once installed MikTex I had the same behavior. It installed fine and then suddenly it reverted the install again. I had to install it as administrator and then it installed correctly.

update:
I noticed there is a backup folder in the Scrivener folder. The backup Scrivener.exe works just fine.


I’ve sent an email to Scrivener Windows support already.

I opened Scrivener, allowed the auto-update to run, and when it finished with no errors, I attempted to open my latest project. I have attached the error message as a JPG.

Opening Scrivener from the start menu also yields a similar error.

Just thought I’d post a heads up to the community.

~ Edward.

edit: Added eventlog for side-by-side error.

Activation context generation failed for “C:\Program Files (x86)\Scrivener\Scrivener.exe”. Dependent Assembly Microsoft.VC90.MFC,processorArchitecture=“x86”,publicKeyToken=“1fc8b3b9a1e18e3b”,type=“win32”,version=“9.0.21022.8” could not be found. Please use sxstrace.exe for detailed diagnosis.

I did a little more research on the error message:

This application has requested the Runtime to terminate it in an unusual way

It lead me to the following link on Microsoft that makes absolutely no sense to me. (I’m an author not a programmer.) I have no idea how to change various C++ switches. But it would appear that y’all have a bug. Here’s the link:

support.microsoft.com/kb/884538

I’m going off to start a support ticket on this. Upgrading software shouldn’t be this difficult.

I can’t install the update at all. I keep getting this error message:

Error trying to install file: destination $(installdir) resolved to an empty value

How do I fix this?

I have the same symptom; see attached screenshot.
Scrivener error edit.png

For those of you seeing the “side-by-side configuration” error, the issue can be resolved by downloading the “Microsoft Visual C++ 2008 SP1 Redistributable Package (x86)” at microsoft.com/en-us/download … px?id=5582.

I have installed the update, I use windows 7 on a dell 19 laptop that is about two years old. I have not had any error messages and it seems to be working fine, I hope I have not tempted fate by saying that lol :smiley:

Yeah, try reinstalling the C++ library, if you’re having issues. Sometimes it gets corrupted.

I can’t install the update at all.
It goes to installing update – and tries to create a folder on Q:\ – which happens to be my USB thumb drive.
There is NO way to change it, I’ve taken ALL the Q:\ references out of the registry and it STILL wants to install to my USB drive.

TBH – Thank GOD it tried to install there. After seeing all the problems people are having, I’m glad it refused to install because the USB wasn’t plugged in.
I’m on a deadline, and being unable to get into the software would be a disaster.
Right now I’ve compiled the novel as a “Just in case” but I can’t risk updates like this taking out the entire program.

Okay, I had this one, too. Completely uninstall Scrivener. Then grab a fresh copy of it, and install that. It should install to the correct directory after that.

To reinforce - the link provided by Eddie Tex to a tiny Microsoft C++ update fixes the error with the update and allows Scrivener to once again open normally.

Many thanks for the existence of this forum and to Eddie Tex for providing the solution.