Windows 3.1.4.0 Cursor is Bold

Cursor is bold at 175% in the editor.
Using Word and the same font and size, the cursor is thin and unobtrusive.

Scrivener


Word

1 Like

Yeah.
They just made the cursor’s size follow the zoom.
I don’t quite like it either.

Not sure I get the point.

Yes. I see it’s from 150% scale and upwards. Looks very old-fashioned.

Should be made optional imo.
Making the text bigger so that it is easier to read doesn’t really require that the cursor grows thicker.
Especially if you tuned it so that it is easy to see at smaller zoom sizes…
The visibility of the cursor actually has nothing to do with the text size, by zoom or by font size.
It’ll grow taller with zoom, ok. But wider? meh.

(It is not a catastrophe.)

I’ve seen people moan they can’t find the cursor. Let them have the option.
It’s an irritating eyesore and old school.

1 Like

There is already an option to set it as wide as one wants.

image

image

2 Likes

Oh, the horror of a true block cursor again.

Thanks, I’ll look into it later. Hopefully, I can reduce it and in so doing not affect the smaller areas, like when writing in the Inspector, where the cursor is it’s normal self because there’s no scaling.

My ‘Use block insertion point’ is off. The minimum it can be set to is 2 pixels. Based on the thickness of 2 pixels, I’d say it’s defaulting to 1 pixel in version 3.1.4, even with the option turned off.
My view is that the old implementation should be restored and not linked to the block insertion point.
I installed the 3.1.4 patch to address the synopsis cursor behaviour, and while that is sorted, this remains -not that there was any commentary from/commitment by L&L on this.

The hairline cursor scaling with the editor zoom has been fixed in the current 3.1.4 release. Download a fresh copy of the installer and run that (over your current installation is fine) to get the updated version with this adjustment. You may need to toggle the block cursor setting after installation in order to see the change.

1 Like

Thank you. I confirm it is fixed, displaying a hairline cursor again.
My ‘Use block insertion point width’ in File > Options > Editing is unticked.