Windows Beta 19-21 Crashing

Has anyone else noticed their Scrivener 3 beta crashing pretty consistently? I’ve seen mine freeze and crash semi-predictably. Conditions to cause crashing: leave open and unused for some time (30-120 minutes), attempt to add text - crash.
First noticed in beta 19, still continuing in RC1 which I worry about. Both Windows 7 and Windows 10. All files are left intact and all changes saved.

No, can’t say I have. Otoh, I generally don’t leave Scrivener open like that.

Just one project, or any project?

I don’t remember Scrivener ever crashing to me. Nighter the beta nor the old version.
Where do you save your files? On an internal HDD, external, etc.?
Do you run Scrivener as Admin?
What antivirus do you use?
All of the above can be a reason for the crashes.
I’m also using Win 7 & 10 by the way.

Check that your HDD which hosts your project is not set to go to sleep after some time.

I’m only working on one project. Might test with another for a couple days.

Saving to cloud storage - could be an issue (will test over the next few days on internal HDD).
Scrivener running as Admin.
Using Sophos Antivirus.
Will continue to test changes to storage (as well as use different, smaller project) and report back soon.

Beta 21 - the latest release CRASHES HORRIBLE EVERY TIME for me as well. The instant I pr.ess compile. BOOM, the entire scrivener software just flat out craps out and I have to reload ALL my work.

It’s the most horrendous, unstable piece of software I have ver seen. Totally unusable.

I hope you get this fixed soon, as I really like the tool and hate to see other suffering the same way I am with this nonsense.

Thanks. Looking for Beta 22 soon, I can’t imagine this version unleashed on the scrivener community.

THanks.

I’ve noticed no problems. I work a lot on about 5 scrivener projects. Can’t remember having any crash in a year. In out. writing exporting. dragging dropping. Doing lots of stuff. Have maintained latest Betas since about b10

On Win7. I haven’t had any problems either.

Compiled both a chapter and the full manuscript of my longest WIP - no crashes. It froze on the compile of the full manuscript but I suspect that’s because it’s pretty long. Running RC1 on Windows 10.

Kind of wondering what kind of project that is, to cause that. I have no issues compiling (although it’s slow for a project of millions of words and hundreds of images).

My suggestion is to do a clean install of Scrivener and see if that helps (that is, uninstall the software; remove the directory it was in [completely], download Beta 21 again, and install again from the new download into a brand new directory). Because it sounds like something’s corrupt.

If that doesn’t work, the problem may be in your project.

I agree with you that a constantly-crashing program is useless. Yet it doesn’t do that for me or for many other folks (it has other issues, but crashing isn’t one of those).

I updated to Scriv Beta 21, RC1, With prior beta I had no crash problems until this morning (Win 7 PC with 16GB memory). From 07:00 - 08:30 it crashed each time about 30 seconds after loading — without me touching anything. Only other programs open were Firefox (latest) and procexp.exe. I have not installed new software recently. Same version of Scriv working okay on Windows 10 laptop.

This time of day not being the best to tax my two brain cells, I tried to go through basic steps. Restarted the system, loaded Process Explorer to identify any processes with heavy load or unusual behaviour (it’s also good at detecting viruses: right-hand column for those that want to know), started Scrivener and — same thing. I updated Win 7 (which took a while, as usual), and after a system restart fired up Scriv — same problem (if I’m honest, plus a few swear words).

Next, I looked for what Scriv was doing by first reloading it, then checking with other tools. I could not open or close Scriv projects, or point and click the cursor to do anything in Scriv to invoke a response. This suggests that whatever Scrivener is doing that fails, it’s part of loading processes. Restarted my system, loaded Process Explorer, and this time started Wireshark to observe network traffic. 14 seconds into Scriv startup I see a call to 151.101.2.49 (Fastly cloud servers, Kansas USA: AlienVault reports 3.5K+ URIs using same IP). Now one of those two brain cells is wondering if Scriv crashes because of an unsuccessful calling-home procedure. For GDPR reasons this sets the other brain cell shouting about why a UK company is using my system to do anything within the USA, the European Court having ruled that USA is not safe for data. Whether or not there is a calling-home procedure, Scriv crashes soon after it.

It’s now 10:18 and I’m probably going to lose my day’s work, the thoughts I woke up with having diminished into the ether. Hopefully, though, this will add to the pile of feedback and trigger an urgent response.

For sure, whilst crash issues continue, Scriv is not at RC1. Devs may consider renaming.

HTH…

I must say that we are surprised too. We do not connect to any external IPs. We connect only to Paddle servers(our license provider) for activation and verification. The license activation is disabled in the beta builds, so no external connections should be started. There must be something related with your computer and installation or project, which triggers this connection.

Thanks for a fast response Tiho.

I’ve wasted a morning on this in an attempt to assist. These are my findings…

  1. That Scricener 3 RC1 for Windows crashes within 30 seconds whilst it continues loading
  2. This occured on my Windows 7 PC running in both nomal mode and safe mode with networking, but worked okay in safe mode with command prompt (no networking)
  3. That others have reported the foregoing critical problem
  4. Scriv 3 RC1 works on my Lenovo Legion laptop (64GB memory) with Win 10 OS
  5. This issue cannot be my PC, I’ve just arrived back from two months in the Middle East and China attending conferences (like https://10times.com/tase-guilin), meeting my development teams out there, and writing a book. All I’ve done, apart from that mentioned this morning, is update Scrivener

Possible: Given that I’ve just updated to RC1 and it works in Win safe mode without networking, there’s a network related issue been introduced recently.

With 50 years in systems development and running companies it comes hard to receive an “it’s the customer” response. I had recommended Scrivener with free ads across our systems until now, and generally elsewhere. I’ve instructed my colleagues to remove recommendations until at least three months working operation after release. I’m now concerned about the development mindset here, a pity given L&L are a fellow British organisation. One reason why I recommended Scriv is because we have an automatic book production system, for ordinary folk to publish full or part books and other documents, with subscriptions so authors can increase income from their hard work. Our system requires Latex files, which Scrivener is wonderful at, especially with Markdown. I’ve instructed a development team to look at a Markdown editor that can be modified to included inline Latex commands (like Scrivener does with HTML comment tags) and produce Latex output so that we don’t have to wait for a Scrivener fix.

Scrivener is a good product. I do not want to unfairly criticise. Crash “bugs”, though, are serious. I’ll see what else I can do when I have time, but not today.

For anyone else experiencing this issue, try starting your OS in safe mode with command prompt mode, change directory to your Scrivener installation folder, and run Scriv from there, If it works, restart your machine in normal mode, turn off your firewall/anti-virus software, and run Scriv again. If it works, look for the problem within your firewall/anti-virus software — and don’t forget to turn it back on. In my case, that wasn’t the issue, Scriv still fails. Good luck!

I’ll still buy Scriver when V3 is released, to regain confidence.

HTH…

Yeah, it must the software… nevermind you’re the only one who experiences the said problem out of the thousand other customers. It just makes sense, right?

Testing this further I can confirm that the Scrivener’s source code does not trigger any external communication, except checking for updates when using Help > Check for Updates. If some of the Qt or 3rd-party libraries(like Google Breakpad) within Scrivener initiate any network communication we have to trace further.

@Krastev… Perhaps you should carefully read the reason from the OP, the thread as a whole, and take into account that thousands of users cannot be bothered to respond, feel they don’t have confidence in their technical ability for providing feedback, or will be abused if they try to give feedback.

For certain, there are at least three people, unknown to each other, on different systems, who experience crashes. Presumably, given your confidence in responding, you have significant technical ability. Are you able to assist discover what’s causing the crash issue? Before product gets to market and faces wide reporting?

In my case, I spent time providing feedback to developers after investigating for the the purpose of helping.

Okay. Looking at it. Haven’t had to use Wireshark in a while.

Why would Scrivener call that IP?

“surfing” to that IP, it says

[code]Fastly error: unknown domain: 151.101.2.49. Please check that this domain has been added to a service.

Details: cache-sea1042-SEA[/code]

Suspicious.

What else do you have that would call that IP? Because my copy is doing nothing like that.

Scrivener checked 69.163.177.169 for updates.

193	114.735497	192.168.128.13	69.163.177.169	HTTP	269	GET /scrivenerforwindows/UpdatesScrivener3Betax64/updates.xml HTTP/1.1 

And nothing more. Okay. I’ll uninstall and reinstall, see if something changes for first run.

Hmm. Scrivener called nothing on reinstall. However, AVG immediately phoned home about the application.

Still having crash issues, Not as frequent and generally only whilst sleeping the computer (to fetch a much needed tea/meal). RE Cloud storage - storing on a local copy which syncs with the cloud storage. It appears the conversation has since digressed beyond my technical expertise - good luck!