Won't even start! Help meeeee![FIXED]


Well, and so I downloaded it, and installed it with no problem, but when I try to open it I get an error message saying “This application has failed to start because application configuration is incorrect. Reinstalling the application may fix this problem.”

So I tried reinstalling, but that didn’t work, and I tried downloading it again and reinstalling that way, and that didn’t work, and so now I am so sad, because I have heard that Scrivener is wicked and I was excited to try it.

Anyhoodle, I’m running Windows XP and always have done, on this computer. The computer itself is a few years old but generally very reliable.


There are some scattered XP problems that exist—not everyone is experiencing them; you might try beta 2 when it comes out in a week or so.

Will do. Thanks!

This is a little odd – I had the same problem; a fresh install of Scrivener wouldn’t start up, with “This application has failed to start because application configuration is incorrect”. Tried it several times in a row, including with a reinstall.

However: in order to clip a screenshot of the error and get it out of the virtual machine I was using (I’m trying out the Windows version under VirtualBox so I can see if it’s worth buying a netbook for!) I installed Evernote (evernote.com). And then when I started up Scrivener, it worked.

Maybe the Scrivener installer misses a library (or some registry settings) that the Evernote installer successfully installs?

Either way, if you’ve got this problem and are desperate to solve it, it might be worth installing Evernote to see if that does the trick for you, too…



This is a known issue, and as far as I’m aware it has been fixed in each case by updating Windows to make sure you have all the latest .NET framework stuff installed from Microsoft. There was mention of the Visual C++ redistributable as well.

In any case, if you go to windowsupdate.microsoft.com and get all the .NET updates (you should keep your system up to date anyway) then this will probably solve the issue.

I also saw a note to the effect that Service Pack 3 is recommended, so older machines may or may not meet this requirement.

There is a little part of me that wonders if some of the issues people report (and let me make it clear, I’m absolutely not accusing anyone specifically of this) are down to ‘dodgy’ copies of windows which don’t qualify for automatic updates from Microsoft. If so, this is likely to be a bigger issue for the Windows version of Scriv than the OS X one, especially as there are so many configurations of Windows out there.


Well, if someone could give me a hand with how to do THAT when I just keep getting “unknown Windows error”, I’d appreciate it.

Don’t feel bad, eidolem. I’m going through the same thing.

I use XP as well and, though I was able to get the program to install, I’m unable to create or open any projects, which makes the program unusable at this point. I’ve tried every suggestion I’ve seen on the boards here, fully updated my system, installed various programs and nothing has resolved the problem for me.

I was really excited about the release and so disappointed when it wouldn’t work on my computer. But, I’m going to be patient and wait for a later beta and try again. I’m sure they’ll work it out eventually. I have confidence in them and from the praise I’ve heard so far it’s going to be worth the wait.

Are you running Office 2003?

If so, see if this information is useful: support.microsoft.com/kb/949074
It was originally linked to from: social.answers.microsoft.com/For … 4e9eeb8aad which described someone getting the same error you cite (although they were on Windows 7, the problem may be related).

More information here: support.microsoft.com/kb/903772/


I’m on Vista with Office 2007, but I think I may have found the fix… windows is currently downloading 122 updates that it managed to find.

Now, if it can just do that and leave me time to play with Scrivener (if I can get it working) before I have to leave for work in an hour, that would be GRAND.

I was having the same problem, also on an XP machine, and I used the trick mentioned above and installed Evernote. Now it opens! Thanks! :smiley:

Hi Eddy,

Are the .NET framework and the redistributable stuff even installed with a base install of Windows XP? The .NET framework post-dates XP and (at least most of) the VC++ redistributable stuff was never bundled with Windows. They’re just both so common that they’ve made their way onto the vast majority of XP machines because almost everyone has installed a few software packages that rely on them. Once they’re there, they’re updated, but I don’t know if they’re installed by the update process if they don’t exist on the machine in the first place.

As a point on the graph, my copy of XP is totally legit, but it’s also very bare – I’m running it purely for website testing (in a virtual machine, on a Mac.) Hence, it’s a standard Windows XP Home install, with IETester installed for web testing, an anti-virus package, and all the latest updates from Windows Update. And, until Scrivener came along, nothing else. Which I’m thinking might be why Scrivener didn’t work…



Incidentally, to see if it is the .NET framework that’s the problem, can anyone else having this problem try just installing the .NET framework:

microsoft.com/downloads/en/d … laylang=en

…and see if that fixes the problem?

To be honest, I’m primarily a Mac user these days and have been for some years so I’m not up to date on what Microsoft does currently. I’m pretty sure that the .NET framework never used to be bundled as standard but so many applications rely on it these days that I’d be surprised if that was still the case.

Checking my virtual XP machine (which runs the Scriv beta just fine), I note that in the ‘Add/Remove Programs’ I do have the Microsoft .NET frameworks 2.0 and 3.0 listed (I have a Visual C++ Express development environment on this machine, so the indicated sizes may be larger than you would expect, I’m not sure about that):

[Edit: viewtopic.php?f=32&t=9032 indicates that .NET is not required to run Scriv beta]


I’m looking into this to identify exactly which file or files are causing Scrivener not to run. It’s taking some time - please bare with me I’m having to go through file by file and there are hundreds.

This might be a case of the same issue that drove me crazy trying to install to XP.

Try searching for Visual C++ 2008 Redistributable and installing it (the version of the file I used was called vcrun2008.

Good luck! :smiley: