Word count is ignoring footnotes

My Scrivener word count appears to be ignoring footnotes, even though I have asked it to include footnotes. The number I get from Project Statistics, Project Targets and Text Statistics are the same, 5068 words. However, I noticed that this number didn’t change when I deleted a large number of words from a footnote, and when I compiled to check the word count in Microsoft Word I discovered that Scrivener is ignoring almost 1000 words of footnotes.

Since my total word limit, including footnotes, is 12,000 this is quite a big margin! Am I missing something that I need to set or unset in order to get at least one of the Scrivener word count tools to include footnotes? The footnotes are in the sidebar, not inline, if that makes a difference. I really don’t want to make all my footnotes inline as they are references and it would make it very hard for me to read what I’ve written.


I have the same problem. I tried turning ‘exclude footnotes’ on and off again but the word count is the same either way. Since my book is probably 15% or 20% footnotes, this is a bit annoying.

Thanks for catching this, though I’m sorry about the inconvenience. The bug is limited to the inspector footnotes; inline ones are being properly included or excluded according to the settings, but as the inspector notes are outside the regular stream of text, they’re evidently being inadvertently constantly excluded. Converting them to inline notes would work for now to get the correct count, but I understand that it’s not the most convenient; you may rather just run off a quick compile and check your count in Word. (Keep in mind also that the word counting algorithms will vary from program to program, so even with this bug fixed, you may get slightly different counts from Scrivener and Word, based on things like whether a hyphenated word is counted as one or two.)

Thanks for confirming that it’s a bug and not me being useless! As you say, compiling and checking the wordcount is a temporary fix but I look forward to when it’s fully resolved :slight_smile: Considering how useful Scrivener is otherwise, I’ll forgive it this one hiccough!