Word Crashes With Scrivener-Created Docs

Hi guys,

I just exported a basic document (no tables, no images, no special fonts or formatting), about 300 double-spaced pages – using the “improved” .doc/docx exporters in Scrivener, and every time I do it – with either doc or docx exporters – the resulting document causes Word 2011 to crash on my Mac. No other documents cause this – only those created by Scrivener. Pages also crashes. When I use the standard RTF exporter, I don’t get page-breaks. So is this a known problem, or something new?

–Andy H.

Very strange - no one else is reporting any problems with this, and everything is working fine my end. I have just tested exporting a 320-page document to .doc and .docx, and it opened fine in Word 2011 and Pages. I also tried exporting a more complicated document with comments and images, and again it worked fine.

Incidentally, the standard RTF exporter does include page breaks, but you must open the file in Word, not Pages. Pages is really bad at reading RTF files, and ignores their page breaks, headers and footers, images and suchlike. This is a fault of Pages, not of the RTF exported by Scrivener.

I’ve attached a 320-page .docx file exported from Scrivener that opens fine in Word and Pages on my machine - could you please try opening this in Word and Pages on your computer, to see if this presents you with the same crash?

Do you get the crash for all documents you export, or just this one?

Thanks and all the best,
Keith
largenovel.zip (13.4 KB)

I tried opening the file, but I get the same result . . . Word crashes on open. I also tried Pages, and that works fine. WHen I try to use Pages to open my resulting .doc/.docx file, though, which is about the same length, it just hangs on the progress indicator. Very strange indeed.

–A.H.

P.S. I’ve attached the problem file… see if it opens up for you.
The Reality Engineers.docx.zip (401 KB)

The file opened fine for me in Word, and it opened in Pages but took a long time to process and had some warnings. The warnings were about missing fonts, which just means that the document uses fonts you have installed on your system but that I don’t have on mine. The fonts are:

LegacySerifStd-Medium
ComicGeek
MaskedMarvel

As fonts are notorious for causing problems on OS X, my guess would therefore be that it is one or more of these fonts causing the problem. As a test, I would try overriding the font during compile to ensure that the document uses none of these fonts, then try opening that in Word or Pages. If it opens fine, then you know these fonts are the problem. (Remember that if you have any documents that use these fonts set to “Compile As-Is”, they will ignore any font overrides and still use these fonts, though.)

All the best,
Keith

Actually, I tried exactly that earlier. Didn’t work. :frowning: I suspect my Word install might be bad, because I recently had to reinstall due to database corruption. I’ll tinker around with it and let you know what I find.

Update: RTF works fine in Word, and Pages (though is of course missing features). The old doc/docx exporters work, too. Its only docs created by the new “improved” exporters that cause the problem. All other output options work fine, too.

No need for the quotation marks - they are improved. :slight_smile: I suspect a bad Word install your end too, then, if it’s not the fonts, seeing as the problem is limited to your computer.

All the best,
Keith

Yeah, that probably IS it, actually. Word has never worked well on 10.8, so I suspect an incompatibility. That and OS X’s font management isn’t the greatest in the world . . . so perhaps there’s a conflict there. I put “improved” in quotes because I wasn’t quite sure they were :slight_smile:, but they DID work before Word 2011, so perhaps once MS updates it to work better with ML, then these problems will go away.

The new .docx exporters support images, headers and footers, end-of-page footnotes, comments and suchlike, whereas the old standard ones don’t. For the record, though, I’ve been testing on Word 2011 running on Mountain Lion, so there must be another factor too (it may be the font conflict, though).

All the best,
Keith

Yeah, because if I export from Scrivener as RTF, and then load it into either Word or Pages, it does just fine except for that font. That’s got to be it. Oddly, though, when I load the RTF into Word and then save it as a .doc file, Pages STILL chokes on it. Don’t know what to do there. But yes, I’m certain that that’s it. Although, I tried it earlier just using Courier in the Quick Font Override panel, and Word still crashed upon opening it. So I’m not sure where to go from here, honestly, unless you know someone who’s got lots of experience troubleshooting Office for Mac. :confused: And iWork, too, even if the whole thing’s in Courier! ('Cause Pages chokes on it no matter what. But oddly, I’ve got 500 page .doc files that it opens just fine!) So, yeah, kind of stumped…

The fact that Pages chokes on the file even after it has been loaded into Word as an RTF and saved out as a .doc file from there at least rules out Scrivener’s exporters as the culprit - when you Save As from Word, it creates a .doc file entirely using its own routines and encoding, as though the whole document had been created in Word from the start. If I were you, I’d use the old debugging trick of halving:

  1. Load the RTF in Word and save it as a .doc. We already know that crashes Pages, so…

  2. Cut and paste half of the text from Word into a new file and now save two .doc files, each containing half of the document. Try loading each in Word.

  3. If one half loads fine and the other doesn’t, then you know the problem is in one half of the file. Continue halving it until you narrow down the problem piece of text.

If both halves still cause problems, then you may want to try randomly saving smaller segments of the text, to see which is causing the problem.

All the best,
Keith