Word wrap doesn't seem to work

I did some searches and couldn’t find an answer for this. My words don’t seem to be wrapping as I type. When I hit enter it acts like a new paragraph. I can’t seem to find any settings to fix this. I haven’t tinkered with the template I’m using, so I don’t think it’s something I messed up. Here is a screen shot showing my text going beyond the marker that marks the right margin:

(you may have to scroll to see the right margin)

Does this happen also in Composition Mode, or in Full Page?

And have you checked the setting at Preferences > Editor > Default editor width?

ps

I’m kind of new to this, so I might sound like a dolt. I don’t know what composition mode is, but I assume that is the mode pictured in the previous screenshot. It happens in full screen as well. Here is a screenshot of my settings. I haven’t changed anything here from the default.

Maybe I’m creating the wrong kind of document? I’m basically right clicking on the corkboard and selecting add -> “new text” then selecting the document in the binder.

I’m using the comic script template, if that matters. I did just try the fiction short story template and it did the same thing.

(again, I can’t figure out how to size attachments, so you may need to scroll)

If you get a scroll bar at the bottom of your editor, then it’s due to your having a non-zero Default Text Editor width. In most Script writing modes, I think this is done, along with the page view, to give the writer some sense of how many pages they’ve written without doing a compile (which is the only accurate way to assess that).

If you want the editor (text area) to use 100% (no more, no less) of the available space, wrapping text so that it all falls between the binder and the inspector, then you need to set your editor width to 0.

Other options:

  • Un-check the “Use fixed width”

  • Click on the Use Current button to have the editor re-sized to fit your current editor’s width.

  • Reduce the zoom level of your editor* is smaller.

  • View->Layout->Show footer bar if there is no zoom percentage showing at the bottom of your editor.

I am new to Scrivener, just trying it out, and I have a similar problem.

When I split the editor, the left panel editor word-wraps fine, the right one does not; when I switch the panels, the faulty panel switches too.

I tried what you suggested with width etc. But it does not work, one panel word-wraps, the other does not. I have the impression, when split-editing the editpr preferences aplly to both panels anyway.

Any idea how to fix that behaviour?

For my planned use of split editing, this renders Scrivener pretty useless; would be a pity to have to go back to Word or Pages.

Tank you in advance.

Just a guess, might want to select each panel and check to see if they editor settings remain the same. Might be able to have different editor settings for each panel. Just a quess, Im new to scrivener as well.

Thank you! I did try that, did not see any change when going from left to right editor and back.

Looks more like bug than like a feature to me, but an experienced user might know more.

I’m revisiting this because I still haven’t been able to get it to work. I’ve been able to work around it since word wrap seems to work on my script pages. It’s only on my notes pages and synopsis page that I have this problem. There’s no scroll bar when the text goes off the screen. Any other thoughts on how to fix this?

Maybe it is a bug?

OK, so it seems that within the same document word wrap works. The very first line doesn’t wrap, but after making some notes for a story I’m working on (and hitting enter at the end of each line) I inadvertently went beyond a line and it wrapped.

Odd.

I don’t see any word wrapping option in Scrivener 1.5.0.6 beta linux
there is no “wrap to editor mode” that I can see
below is screenshot of editor options.

[Later Edit]

I found this post by searching “word wrap” but I now see that it refers to Mac
and I am running Scrivener Linux.

In fact I can’t find any of these wrap preferences …

scrivenerwriter.com/all-the/all-the-preferences/

Wrap to Editor Mode Default width Editor
Wrap to editor Mode Margins Editor
Wrap to Page Mode Center pages Editor
Wrap to Page Mode Draw shadow around pages Editor
Wrap to Page Mode Show margin guides Editor
Wrap to Page Mode Show page view in new projects Editor
Wrap to Page Mode Use facing pages in new projects Editor

You’ve posted in the Mac forum, and as you’re on Linux, you might do better to repost in that forum. You’re more likely to get help any help that’s available there.

Good luck.

Mark