Word wrap in editor inconsistent

I usualy work in the editor with inspector off to max screen width, and so use the inspector when (for example) adding an inline footnote or editing the synopsis.
However, when I then leave the inspector on, and go back to the editor, text flows across the screen without wrapping and so unable to read document.
This is an inconsisent problem, hence difficult to replicate or identify what is contributing to it
Closing inspector does not always help.
Opening new doc in editor fixes

Any ideas helpful
thank you

There are two potential things that could cause this:

  • There is an obscure and difficult to reproduce bug in macOS that causes it to miscalculate how wide a text editor should be. This can cause text to flow outside of the view area—usually by a small amount. The only known fix for this problem is to reset the project’s UI settings.
  • The other potential is an intentional feature: you have View ▸ Text Editing ▸ Show Page View enabled. In this mode, text layout is done to a virtual page rather than the editor width, and so if the editor is narrower than the page you will have to scroll around to see all of the text—as is typical for this kind of presentation in word processors, etc.

From your description, it sounds more like the former to me, especially if it sometimes happens in the same editor. Page View is not a per-document setting, but per editor. So the only point of ambiguity there is if you frequently open and close split views, and sometimes end up alternating which editor split is “home”. Since each split has its own Page View setting, that can mean the effect comes and goes, seemingly at random until you know the pattern.

Thanks Amber.
You were right with the former – it was a UI bug.
FYI I found (from your comments) how to replicate the problem.
Document open in editor without inspector appears correctly
Split editor in horizontal plane … both documents appear correctly
Open inspector … top document fails to wrap, bottom document wraps correctly

The layout fix worked