Wordcount includes annotations

The running wordcount includes annotations.

Since annotations are generally not included in a final document, I would have thought this was a bug.

E.g. if I have to write a document to a specific length, annotations generally won’t count.

Project > Project Statistics > Options > Exclude Annotations :wink:

This isn’t a bug, just a necessary compromise for speed. The word count in the editor footer and in Project Targets uses the text that loads in the editor, whatever that text is. In order to get a more accurate count based on your compile settings, Scrivener actually needs to run the compile in the background, so this can’t be done on the fly while typing without causing a lot of lag–if you have any large projects, you’ll see it takes a second or two for Project Statistics to come up or to compile your project; it’s just not feasible to do that continuously for live counts.

As temporalranger says, Project Statistics is what you’ll want to use, since this does run compile to update the draft count based on the specific current settings, which means if you’re excluding annotations from your compile, they’ll be excluded from the count here, and if you’re adding titles, they’ll be counted here. For counting only selected documents, the Options tab in Statistics will give you refinements like excluding annotations.